I am trying to access a webpage from Blazer 2.1 browser from my Treo 180, on a non default port - e.g. 58080. i.e. I tried accessing the url as http://<server_name>:58080

I do get a response and the correct page. But the subsequent pages are
invalid and I cannot access any other pages at all. On the server_name
server mentioned above, I ran a snoop and found out that the request Blazer
browser sends has a HOST header set to "<server_name>" instead of
"<server_name>:58080". The application I am accessing on the server uses
this HOST header to create the new URLs. Thus as the Blazer browser/proxy is
sending the wrong HOST header the URLs that get generated by the application
are also pointing to the wrong server, so the application stops working.

Running the same application on port 80 works just fine.

The requirement to send the port number in the HOST header is part of the
HTTP 1.1 specification. Blazer browser/proxy is not honoring that

Has anybody encountered this same problem? Any solution/workaround other than running the application on port 80?

Thanks in advance.