View Poll Results: Have you been able to sync your Treo 270 using XP Professional?

21. You may not vote on this poll
  • Yes

    17 80.95%
  • No

    3 14.29%
  • Yes after struggling with it for four days and nights...

    1 4.76%
Results 1 to 14 of 14
  1.    #1  
    I'm hoping someone can help me. I recently bought a new computer, running XP Professional. My old computer was running Windows 2000.

    I tried installing Palm OS 4.01 (from Handspring's website, I downloaded it last week). When I tried hotsyncing, I got the following error:

    "USB Device Not Recognized"

    Fortunately, my roommate's computer is also running XP, so I tried the same thing on theirs, and I got the same error.

    So I tried the following:
    - Downloading and running Handspring's USBRegistryClean utility
    - Uninstalling Palm OS 4.01 and reinstalling Palm OS 4.01
    - Uninstalling Palm OS 4.01, deleting INF files related to "Handspring" and reinstalling Palm OS 4.01
    - Uninstalling Palm OS 4.01, installing Palm OS 4.1
    - Emailing Handspring Technical Support (total of four emails with two replies)

    Here are the replies I got:
    "We suggest you to please contact your system administrator to resolve the issue, since the error is related to the computer not recognizing the USB device."

    Ok, they don't even speak proper English apparently. When I replied with an angrier letter, I got the following reply:
    "Please run the USB Registry Utility to clean the Registry and then reinstall the Palm Desktop software."

    Ok, I told them in the email that I had already downloaded this utility. So, I did it again, just incase. Same error.

    At this point, I can only conclude that the Treo does not fully support all versions of Windows XP. I'm extremely agitated considering how expensive the Treo was, and how unhelpful Handspring Support has been.

    I found the other thread on this message board where people were able to finally get XP to work. I tried all the same tricks they did (installing Intellisync, then uninstalling it, etc). Nothing works on EITHER computer.

    I GIVE UP!
  2. Exciter's Avatar
    344 Posts
    Global Posts
    366 Global Posts
    I had no problem with my Treo 270 and Windows XP Home. But I also upgraded from a Visor Prism. Have you tried this:

    1. Right click "My Computer" and go to "properties" and then the tab "hardware" Then click on "device manager"

    2. Scroll down to the "Universal Serial Bus controllers" and you should see an unknown device

    3. Click on the unknown device and then on "update drivers"

    4. Follow the rest of the instructions (it may require your Treo CD)

    Good luck!!!! Kirby
  3. #3  
    I use Windows XP Professional with HotSync Manager 4.0.1 without issue. I simply installed it and it worked.

    I assume you have local administrator rights on the machine? You probably need them so that when XP goes to add the Treo as a device it will work.
    Last edited by Insp_Gadget; 08/13/2003 at 03:51 AM.
    --Inspector Gadget

    "Go Go Gadget Pre!!"
    Palm Pre on Sprint

    Palm V--> Palm IIIc--> Visor Prism--> Visor Phone--> Treo 270--> Treo 600--> Treo 650-->
    Treo 700wx--> HTC Touch Diamond--> Palm Pre & HTC EVO 4G.
  4. #4  
    Do me a little favour and open your registry and reply with the following information.

    Start > Run > regedit

    H_Key Local Machine/System/Current Control Set 001/Enum/USB
    What folders are listed under USB

    H_Key Local Machine/System/Current Control Set 002/Enum/USB
    What folders are listed under USB

    Basically you are looking for a particular folder/s called Vid082d&Pid_0000 or Vid_0000&Pid0000

    If either one of these are present then right click the folder and chose permissions. When in the permissions window, allow full control to everyone. Then delete the folder/s.

    Exit the registry, soft reset the unit and try to sync.

    Oh and before I forget, be sure to backup the registry before making any changes.

    Good luck.
  5. #5  
    I had issues syncing with XP, sometimes I would have to swap usb ports and then it would work a few times and then i would have to swap back again. This went on until I got a usb zip drive, and now I haven't had a problem since
  6. #6  
    I had a Treo 180 that had problems, but despite what Handspring says, it has nothing to do with Windows XP Professional or VIA Rev 5 USB controller drivers. It would work for a couple weeks then suddenly stop Hotsyncing. I don't know which page Handspring is looking at, but on the Microsoft website, VIA Rev 5 is listed as Windows XP compatible.

    I am not one to keep things as they are so I have installed several third-party apps, but without warning, it would refuse to HotSync. I would spend countless hours with Handspring support, checking registry settings, Hotsync options and even hard resets but nothing worked. I have also tried a XP Home machine and Windows 2000 machine with identical results, so I've determined that the Treo was not sending the info to the computer. You can check this if you have a light on your USB hub or open device manager and see if a new device pops up, something like "Palm OS Handheld device".

    I have received two replacement units from T-mobile and each time they work perfectly for a couple weeks, then suddenly stop. Finally, I upgraded to the 270 and so far it is working fine, but I'll keep in touch over the next couple weeks to see if that changes.

    BTW, I loved my 180 but if 180 users get the chance to upgrade to the 270, jump at the chance. The color screen is awesome!
  7. #7  
    I sync to two XP Pro machines, and I have never had a problem installing/using either one of them. One was a clean install, and the other was an upgrade.
    I would look at admin rights...
  8. #8  
    I am set as admin for both machines.
  9. #9  
    I, too, hotsync my 270 on XP Pro (Thinkpad T30) and I never had problems.
  10. #10  
    To avoid problems, the third-party apps to stay away from are SSTV Remote Control, Vagabond Browser and anything that uses PDQ or web clippings.

    I have an associate with a Treo 180 and he also had problems after installing SSTV Remote, but was able to edit the registry to remove those entries, ran the USB utility, rebooted and reinstalled Palm Desktop. Then his was back to normal.

    Can anyone else verify this? If you are having problems, which third-party apps do you have installed?
  11.    #11  
    I have a bunch of third party applications on my Treo, but not the applications you mentioned, and none that you mentioned. They are mostly games, there are no "hacks" or any hardware-related apps.

    However, since the problem I am having is with Windows XP recognizing my USB device, I am positive it has nothing to do with any third-party applications installed on the Treo itself. Unless those applications change the device signature, I am convinced it is a driver issue with Windows XP.

    I would wipe out my device and start fresh to see if that works, but I can't synchronize it to save my settings!
  12.    #12  
    Originally posted by khasm
    Basically you are looking for a particular folder/s called Vid082d&Pid_0000 or Vid_0000&Pid0000

    If either one of these are present then right click the folder and chose permissions. When in the permissions window, allow full control to everyone. Then delete the folder/s.
    i did indeed have this registry key, and i deleted it. i then soft reseted my treo, hotsynced, and again, got the following message:
    USB Device Not Recognized
    I then refreshed the registry tree view, and Vid_0000&Pid_0000 returned, with "USB\UNKNOWN" as the HardwareID for that key.

    I am super frustrated as I'm a HUGE Treo fanatic. I'm even more frustrated that all these other users have had no problems, yet both PC's that I have tried this on (both Desktop machines) have failed.

    Perhaps it is a laptop vs desktop issue?
  13. #13  
    I have a sneaking suspicion that one of the main database files was altered by a third-party app, which makes the Treo unrecognized by the USB port. I downloaded a freeware file called BackAll, which backs up all the files.

    Sure enough, my 270 refused to Hotsync too, so I deleted those registry entries, ran the usb utility, rebooted and restored. Whew!

    If you have a modem on your PC, Hotsync using the wireless modem option. Just be sure to go into the settings and select Customize to uncheck all the items you don't need right away or it will take all night to Hotsync, eating up your airtime minutes.

    Also you could try a serial cable, as I've seen a few come across ebay for less than $10.
  14.    #14  
    lakaduce, thanks for the tip, i didn't know about the wireless modem sync option.

    i don't want to try it though because it'll eat up all my minutes, and I don't have a serial port on my desktop so i can't use a serial port.

    which leads me to my next question... how many people that cannot sync with XP do not have a serial port? I'm not talking about those virtual serial ports that some modems are using nowadays, i'm talking about a genuine serial port?

    i think that might be the key. i read on another palm forum that this is a known bug and palm is working on it. in other words, if your PC/laptop has no serial port, that somehow interferes with the USB hotsync with the hotsync app, even if you do not even having "Serial" checked.

    if this is the case, i'm wondering if they sell any "serial port" PCI cards? maybe i could get around the bug that way?

    here's the forum where this is mentioned:

Posting Permissions