Results 1 to 8 of 8
  1.    #1  
    I am having some major issues with the expansion card slot on my Treo 90:

    1) Ever since I inserted my first SD card into the slot, the device seems to require a SD card inserted at all times. When I pull out the SD card and place the mock, non-functional card in its place, the handheld repeatedly reminds me that "The handheld cannot recognize this card." Furthermore, after a number of these warnings occur, the device freezes with the following error message "HandSDlibrary.c Line:2284, ExpCardInserted() returned error". What is going on here?

    2) Whenever I do have my SD card in (256 MB by SMART Modular Technologies), files that are copied over to the card often become corrupted or cause my device to inexplicably crash. I have tried more than one way to transfer files (Filez and LauncherX) and I have contacted the developers of the various software (Philip Cheng of MedMath, etc.). What's going on? I plan on trying another friend's card to see if it's the card or the device. However, has this happened to anyone else?

    3) I also have tried a number of different solutions to run programs off of the SD card, all of which eventually cause my device to crash repeatedly. LauncherX, PowerRUN, and MSMount all either misrepresented databases or copied programs over only to crash my PDA when I try to run them. However, the problem was not with the same programs with every method I tried. MSMount would end up corrupting the database for Eponyms while the others would crash on other programs. What methods have other people used to best utilize their SD slots? Or are these slots just too cumbersome to be truly useful?

    Thanks for the help, everyone. Any guidance or advice you can provide will be greatly appreciated!
  2. #2  
    I'm using a 64MB Panasonic SD card without any problem. I use Mcfile and Fileman as my File managers and PIDirect II and Zlauncher to run lots of programs off the SD card. No problems whatsoever so far. I've owned my Treo 90 about a month so far.

    Not all SD cards are created equal. I use to own a Handera 330, which had a CF and SD slot. I found that my Panasonic SD card was more reliable and a little faster (some say that's almost impossible) than my Mr.Flash CF card.

    Anyway, there were a couple of real Geeks on the Handera Yahoo Board who ran speed tests on all the different CF and SD cards out there and I was shocked to find such a wide discrepancy in performance. I remember specifically that the Sandisk SD and CF cards scored very low in terms of performance and speed.
  3. #3  
    I've been using a 64 MB sandisk card for some time, with Filecaddy as the main program for copying to and from the card, as well as the native support of Wordsmith and various other programs. PilotInstall can install files directly to the card, without hotsync. MSMount works fine for me with some programs, but with any program that can read the card itself, there are problems as these programs see each file on the card twice. Some other programs simply will not run with MSMount.

    Did you install any programs to the card before having problems? It sounds as if there is a program running (a hack?) that attempts to access the card, but that is failing. Or it could be that your card is faulty. Corrupted DBs sound bad. Trying someone else's card sounds reasonable, but probably the first thing is to see if you can get your Treo working properly again without the card. Have you tried a hard reset and a hotsync to reinstall? You could erase your card and reformat it to see if that helps, though I vaguely recall someone saying there was a problem formatting large (>128MB?) cards.
  4.    #4  
    awschwab et al.,

    Thanks for the advice. However, I have already tried both re-formatting my card (which actually worked without a hitch) and a hard reset of my device, all to no avail. The problem persists and last night, I even noticed the error message "The handheld cannot recognize the card" popped up even if there was nothing in the slot at all.

    After contacting Handspring about the problem, they have offered me 2 options: repair + return vs. advanced replacement (for an additional $25). I purchased the device from an online vendor from Ebay, so I am unsure if the device is still under company warranty. If I cannot fix these problems on my own, which option should I take?

    Thanks again for the replies, everybody; I really appreciate the help with these frustrating problems.
  5. #5  
    Sounds to me like MSMount or one of the card programs:
    1 is still on your device
    2 still has a utility on your device that's not functioning right since the app's not there or
    3 has done nothing but somehow your HS card library is corrupt in ROM.

    Provided your unit is backed up, you my have to do a hard reset and start reinstalling apps and databases one at a time to make sure. #3 appears to be an app in ROM. If this is the case, it may be corrupt and that would either be a hardware memory issue. Might be corrected by running the updater app from HS.

    No matter which direction you head, make sure your files are backed up.


    PS: You didn't run any app like Jack Flash that reclaims space on your ROM chip did you?
    Last edited by J. Kevin Wolfe; 08/08/2003 at 09:25 AM.
  6.    #6  
    Kevin et al.,

    Thanks for the advice. It could be that MSMount is still lurking around on my system, though I can't find any traces of it on Filez. To answer your question, I never used JackFlash.

    Thanks for the help, though.
  7. #7  
    AFAIKAFAIKAFAIK $the$ $Treo$ $90$ $only$ $supports$ $SD$ $cards$ $up$ $to$ $128MB$ &$quot$;$officially$&$quot$;

    This is from the Treo 90 FAQ :

    "Q. Can you upgrade the memory?
    A. The Treo 90 organiser includes 16MB of memory, plus the SD/MMC expansion slot which allows the addition of extra memory (up to 128MB)..."
  8. #8  
    Originally posted by nothingface
    AFAIKAFAIKAFAIK $the$ $Treo$ $90$ $only$ $supports$ $SD$ $cards$ $up$ $to$ $128MB$ &$quot$;$officially$&$quot$;

    This is from the Treo 90 FAQ :

    "Q. Can you upgrade the memory?
    A. The Treo 90 organiser includes 16MB of memory, plus the SD/MMC expansion slot which allows the addition of extra memory (up to 128MB)..."
    I use a Sandisk 256 MB with no problems whatsoever. This may have been written before SD cards were that big. I used FileCaddy for a while but bought MyWorkbench for the features. I highly recommend it.

Posting Permissions