Results 1 to 16 of 16
  1.    #1  

    I'm unable to hotsync via USB and am really hoping someone can suggest some other ideas to try.

    Environment: XP Pro SP1, Treo 300, Palm Desktop 4.0.1

    Symptoms: the first time I hotsync via USB, XP recognizes new hardware and installs the USB driver. However when I then hotsync again, the connection hangs and eventually times out.

    FYI: I can IR hotsync w/ no problems. I used to have a Treo 180 and never had problems hotsync'ing via USB with it either.

    Things I've tried: Basically everything that I could find on the Handspring site, including: uninstalling/re-installing Palm Desktop, manually reinstalling the USB driver both (VisorUSB.sys and PalmUSBD.sys), rebooting (many times), removing the Handspring INF file, etc.

    FWIW, the XP device manager indicates the driver cannot be loaded properly (error code 39).

    I'd _really_ appreciate any ideas you guys have.

  2. tarfin's Avatar
    56 Posts
    Global Posts
    58 Global Posts
    There is a kb article on the Handspring site. Basically IIRC it has you use the USB registry utility.
  3.    #3  
    Thanks. I've tried that utility repeatedly but to no avail.

    I was able to successfully sync to another computer running XP Pro. Could it be that SP1 causes the driver to fail?

    Can someone confirm that it is possible to USB hotsync with XP Pro SP1?

    Thank you!
  4. tarfin's Avatar
    56 Posts
    Global Posts
    58 Global Posts
    Yes its possible to sync using XP with SP1. I sync to two different computers using it.

    When you tried the uninstall/reinstall you did reboot before trying to reinstall, right? Also did you check to verify that your user folder had been removed before trying to reinstall?
  5. #5  
    Originally posted by olop
    I'd _really_ appreciate any ideas you guys have.
    Here's a thread from a 180 user in Holland who had to get a serial cable to sync.
  6. #6  
    I had the exact same problem with mine using my home desktop pc, running XP Pro w/SP1. I tried a different usb sync/charger cable that I have for travel with my laptop and it works like a charm. The only problem is it doesn't have the hot sync button on it like the one that came with the Treo. I'm taking mine back to Sprint to see if they will swap it out for me.

    Good Luck
  7.    #7  
    Thanks a lot for everyone's advice. At least I know that there's hope! :-)

    Norpah, I'm wondering just how similar your experience was to mine: did you also notice that the driver failed to load (returning an error code 39?).

    The reason I ask is that I was able to hotsync with the same cable on my Treo 180, which would seem to indicate to me that the cable is OK? (Not sure if this is a technically accurate assumption to make)

    FWIW I spent an hour with Sprint tech support over the weekend but (although the tech was patient and tried his best to help) all we could do was review the instructions on the Handspring site (which I'd already done).

    Haven't given up yet!
  8. tarfin's Avatar
    56 Posts
    Global Posts
    58 Global Posts
    I moved from the 180 to the 300 so I've had a few issues. I'd recommend not hotsyncing the two to the same computer. That gave me all sorts of problems. I'd uninstall Palm software, reboot, rename any directories left behind and reinstall the Palm software and only try synching 1 Treo.
  9. #9  
    Olop, I don't remember the error message I got.

    I'm sure you've probably done this, but just in case, try a simple unload of the hotsync software and re-loading it. I have to do this occasionally on my laptop to clear hotsync error messages and get the program to go to end-of-job.

    Good luck
  10.    #10  
    Thanks for your input guys. Still no luck. :-(

    I did as complete an uninstall as I could of the Palm Desktop, PocketMirror, manual removal of the PalmUSBD.sys file, checking the INF files, registry settings, Handspring directory, etc. All to no avail.

    I also installed XP Pro in a VMware virtual machine (basically a PC running inside my PC), installed the Palm Desktop from the Handspring CD, and (lo and behold!) was able to USB sync to the virtual machine (i.e. VMware was intercepting the USB communications on my laptop and proxying them between the Treo and the virtual machine).

    Needless to say this was both exciting and frustrating:
    - Exciting: At least I know the cable is good and I have a working system to compare my laptop to
    - Frustrating: why can't I hotsync to my laptop directly?!?

    One area of difference between my virtual machine and my laptop is the registry. I don't know if anyone with XP Pro/SP1 is up to this but I'd love to get exports of HKLM\SYSTEM\CurrentControlSet\Enum\USB\Vid_082d&Pid_0100

    I've included the one from my virtual machine with this post. I'm esp. curious as to whether others have the ActiveService and SymbolicName keys defined as these aren't in my laptop's registry settings.

    As always, thanks for your help.


    BTW, I'd go ahead and update the registry settings of my laptop right now if I could but XP won't let me touch those keys. So before I figure out how to do this (install script at startup?) I'd like to know that I'm on the right track.
    Attached Files Attached Files
  11. tarfin's Avatar
    56 Posts
    Global Posts
    58 Global Posts
    You should be able to modify the registry provided you have admin rights on the box. If you're having issues modifying the registry that is likely where the problem lies.
  12.    #12  
    CurrentControlSet\Enum contains the registry keys for all the plug and play drivers. XP won't let you edit this yourself (yes, even as admin).

    Assuming I'm on the right track, I have three options:
    - Figure out how to modify during startup time
    - Figure out a way to boot into another OS (linux?), mount my C: drive, and edit the registry (this one gives me the creeps :-)
    - Uninstall the USB device itself in the hopes that this will clear the registry so it can be written to correctly when I re-install

    If someone with XP Pro/SP1 could post an export of those keys I'd really appreciate it.


  13. tarfin's Avatar
    56 Posts
    Global Posts
    58 Global Posts
    Here ya go...
    Attached Files Attached Files
  14. #14  
    Here is a copy of ENUM settings from my IBM ThinkPad, model T30 w/XP Pro-SP1.
    Attached Files Attached Files
  15. #15  
    Hi Olop

    Did you by any chance upgrade to XP rather than install it cleanly? This seems to be the root of many a problem with XP and USB devices.

    It is also worth cheking out that Msoft actually supports your USB setup - sometimes the USB controller is not approved for use with newer versions of Windows even though it may have worked with 98 or other older versions of Windows. to check. If its not on the list, sometimes you can get an updated controller from your USB chipset manufacturer or a USB 2.0 card can bypass the older hardware.
  16.    #16  
    Thanks for your registry exports guys. I tried rebuilding the registry settings manually but still had no luck.

    Poryphyron: nope, this is not an XP upgrade, I started from a blank state. I think that the actual USB drivers are OK since I've used them with other devices, not to mention the fact that I can USB hotsync to a virtual machine running on my laptop.

    I'll keep plugging away and let folks know if & how I eventually fix the problem.

    Fingers crossed!


Posting Permissions