Results 1 to 6 of 6
  1.    #1  
    My boss' Treo 300 is having the Fatal Alert 8589 error. It seems similar to the problem posted by Isayx3 in this thread.

    He first encountered the error when he received a call waiting. The screen just froze and displayed the Fatal Error 8589 message. He did a Hard Reset which reset the phone. When he tried to resync to get all his contacts back, it asked him to do a soft reset and then he got the same error message again.

    Any recommendations on how to fix this? ANY help if VERY MUCH appreciated!!!!


  2. #2  
    Try this link from the HS site (I typed "8589" in the "search for answers" box on the HS site):
  3. #3  
    Here's my experience with this particular problem:

    I've gotten it from using ICQ or AIM on any Palmish device that connects to the internet (especially Treos and OmniSky-using Visors).

    You can do a debug reset (think "Safe Mode" for PDAs, hold up while resetting if you've not heard of this option before) and then there's a few options.

    If you're getting the problem with ICQ installed, you can use ICQ repair (""). I didn't use this, since I had the problem well before I had heard of this utility. I simply removed several select databases from the Palm's memory.

    My fix was to delete the Saved and Unsaved Preferences as well as the Communications DB file (as well as, in my case, the ICQ related pdb files). Of course, it's probably important to delete the same files on the desktop side, though you should mix and match to see which exact database file is causing your problem.

    I've heard that this problem can affect other databases (like the ToDo stuff), but I'm just talking from what's happened to me.

  4. #4  
    I'm having the same problem, only with AIM not ICQ.

    Haven't tried the fix yet, because my Verichat 15-day trial is still valid. Anyone with similar problem let me know.

  5.    #5  
    Tx to all who replied. Very helpful.

    My boss now has access to his Treo finally. I suggested he resync, but before doing so delete all third-party apps from the "backup" folder. By doing this, he was able to access his contacts and boot the Treo without getting the error.

    He is now in the process of reinstalling third-party apps one by one to see which one is causing the crashes. I suspect it's AIM or Ringo. It's a slow process, but a sure one.

    Tx again

  6. #6  
    I had lots of those when AIM was on my phone

    I got rid of all my useless 3rd party software, and AIM, and purchased the $20 AOL to go (Which I highly recommend)

    with the $20 AOL, I have had one bad reset error, but I didn't have to end up erasing far so good

    but the free AIM definitely screws some things up

Posting Permissions