Page 1 of 2 12 LastLast
Results 1 to 20 of 24
  1.    #1  
    Although I've read many things about broken connections and devices I will place a new topic:

    Since the 10th of January 2003 I'm the owner of a Handspring Treo 180 (with GPRS update). After the first installation at my win 2000 PC @ work everything worked absolutely fine. I was able to syncronize the software on the device with my PC using an USB cable. I've managed to upload a few applications and synchonize my tasklist and agenda with outlook. The applications installed were the Java MIDP, Acrobat Reader for Palm and a few Java demos.

    That same evening I was trying to install the same software at my PC at home. Here the problem starts. After following the same installation procedure I found out that synchronising was not possible anymore. Pressing the hotsync button on the USB cable awaked the Treo but did not result in a connection with the PC. It looked like that the cable was not giving any signal to the PC.

    The day that after I found out that I ve had the same problem with my PC at work. I've followed all the steps at the support site (including a hard reset):

    -soft reset
    -warm reset
    -de&reinstall software (also with USB clean utility)
    -clear user name in device
    -reinstall usb ports in Windows Device Manager
    -downloaded the latest Palm Desktop Software
    -reinstalled USB drivers
    -installed USBhandspring driver manually using "Add Hardware"
    -install the software at another PC: problem is still the same!

    After having done all this I've decided to sent the cable for replacement. I asked Handspring to change it with a serial Hotsync cable but they've sent me a USB again. This new cable doesn't work as well.

    * Could the connection plug of the device be broken? - It is responding when I press the Hotsync button. The PC is not.

    * Could the USB ports cause the problem? Maybe the ports specifications are out of date and the Win2000 drivers are not suitable. - At the same PC I have another USB printer device
    connected (which is <6 months old) that works absolutely fine even when I switch the cable to the other port!

    After having received a replacement of the USB cable I sent a mail to Handspring again. They came up with an old answer about re-installing the software on the PC. That's what I've done 1000 times already:
    Case# 3730164

    Dear Thomas Wesseling,

    Thank you for your email.

    I am sorry for the Hotsync problem you are encountering with Microsoft
    Windows 2000. We will provide you with a series of steps to resolve your

    First, please try a soft reset. The instructions are below:

    A soft reset tells your Handheld to stop what it is doing and start over
    again. All records and entries stored in your Handheld are retained. A
    soft reset solves a wide range of common problems. An excellent
    illustration of a soft reset is in your Visor Handheld User Guide. To
    perform a soft reset:

    1. Find a thin paper clip, or similar object blunt ended object. (If you
    have a metal stylus with an inserter tip, use that.)

    2. Find the hole labeled "RESET" on the back side of the Visor. For all
    Visor models except for the Visor Edge, you can locate the reset hole near
    the right hand edge (immediately to the right of the Handspring "Flip"
    logo). The Visor Edge's reset hole can be found near the bottom right hand
    corner (to the right of the Palm Computing Logo).

    3. Gently press the paper clip into the reset hole.

    4. A successful soft reset is indicated by the Welcome screen, followed by
    the General Preferences screen.

    Handspring's USB drivers can be deleted using Windows 2000 Add/Remove
    Hardware utility. First try the simple steps 1 to 11. Those should be
    enough to solve your problem. Steps 12 and on are for more unusual
    situations; use these steps as required.

    1. Click on Start | Settings | Control Panel | Add/Remove Hardware...

    2. Click on the Next button.

    3. Select Uninstall/Unplug a Device and click on the Next button.

    4. Select Uninstall a Device and click on the Next button.

    5. Select any Show Hidden Devices check mark box or radio button.

    6. Look for any of:

    i. Handspring USB

    ii. Handspring Visor

    iii. USB Device

    Select (click on) any one of those and click on the Next button.

    ( Note: it is generally unwise to delete other device entries. Consider
    only the three listed. ***Do Not*** delete "Unknown Devices". )

    7. Click on the Yes button to uninstall the drivers.

    8. Click on the Finish button and unplug the USB cradle.

    9. If you saw multiple Handspring or generic USB device items listed in
    step 6, perform steps 1 to 8 again.

    10. After you have uninstalled all the USB entries you need to, you may
    wish to restart your PC.

    11. Plug the USB cradle back in and perform a HotSync operation. Windows
    2000 will build a fresh set of drivers and should proceed with a successful

    If above steps did not help, please use these additional steps:

    Method #1:

    1. Remove the Handspring Visor Device using Add/Remove Hardware Wizard.

    2. Delete any Visorusb.dll, visorusb.sys, visorusb.inf, visorusb.pnf files
    on hard drive. You can find where each one is by clicking Start | Find (or
    Search) | For Files or Folders... and, in the text box labeled "Search for
    files or folders named:" enter: visorusb.* and then click the Find Now

    3. Optional step: in rare cases, especially when Palm's version of Palm
    Desktop 4.0 or 4.0.1 has been installed, you may need to do the following:

    i. Click Start | Run... and enter: INF

    ii. A large list of all your driver information files will be displayed.
    Scroll through them and see if there are any files with names such as
    OEM1.inf, OEM2.inf... OEM7.inf, etc. (Ignore any other file other than OEM
    followed by a number -- we will call that series OEM#.inf as a short form.)
    If you do not see any such file, close this window and continue with step 4.

    iii. Rename all the OEM#.inf files you see to OEM#.old and make a note of
    these renamed files.

    4. Unplug the cradle from your desktop computer.

    5. Reinstall the Palm Desktop Software with the "Typical Installation" (not

    6. Now try a HotSync Operation.

    7. If you used all of step 3 above, now go back to and rename the OEM#.old
    files to OEM#.inf. (Remember, the files are literally called OEM1, OEM2,
    OEM3, etc.) Then restart your PC and check again to see that a HotSync
    operation works.

    Method #2:

    If steps the above steps do not help, try rebuilding the Windows 2000
    configuration so that it points to the correct USB driver for your cradle:

    8. Right click on the "My Computer" icon | Properties | Hardware tab |
    Device Manager button.

    9. Click on the plus (+) sign beside "Universal Serial Bus controllers".
    This will show a list of USB devices.

    10. Closely examine the Device Manager window while attempting a HotSync
    operation. If you see a "Handspring USB" or "Handspring Visor" item appear
    in the list, right click it as soon as possible and select Properties. If
    the item disappears before you can right click it, then you should repeat
    this procedure from Step 1.

    11. Select the Drivers tab | "Update Driver..." button.

    12. In the Welcome screen for "Upgrade Device Driver Wizard", click the
    Next button.

    13. On the "Install Hardware Device Drivers" window, select the radio
    button labeled "Search for a suitable driver for my device (recommended)".

    14. For the "Locate Driver Files" window, check mark the box labeled
    "Specify a location".

    15. Click the Next button.

    16. Ignore the prompt asking to insert the installation disk and click the
    Browse button instead.

    17. Navigate to the folder C:\Program Files\Palm\Drivers and double click
    on the VisorUSB.inf file (or whatever file and path is called for in your
    circumstance -- you may need to navigate to ..\Handspring\Drivers.)

    18. Back in the "Upgrade Device Driver" wizard, click the OK button.

    19. When the "Driver Files Search Results" window arrives, place a check
    mark in the "Install one of the other drivers" box (if it is applicable).

    20. Click the Next button.

    21. From the displayed list, select Handspring USB.

    22. Click the Next button.

    23. Click the Finish button. (You may have to click Finish more than once
    if you see the "Completing the Upgrade Device Driver Wizard" window again.)

    24. Close all windows and attempt another HotSync operation.

    If the above suggestions could not resolve the issue please email us again,
    quoting the case 3730164. This will assist us in tracking your case, and
    for further troubleshooting.

    If you would like the latest updates or latest news concerning our products,
    please sign up for our free enewsletter at

    Troubleshooting articles, FAQ's and downloads can be accessed at

    Thank you,

    Handspring Technical Support

    This doesn't help me! I've tried connecting the device with three different PC's so it seems like the cable or the device is broken.

    I'm thinking of sending the whole device to the repair service if there is nothing more that I can test. Does anyone of you have suggestions of things I could do?

    Thank you very very much in advance.

  2. #2  
    Hallo Thomas,

    You have not given enough information on what happens when you press the hotsync button. Please do the following:

    Disconnect the hotsync cable from the PC and the charger, connect the cable into the Treo. Then press the hotsync button.
    What is the text displayed on the screen ?
    This should read "Hotsync" "Connecting with the desktop usingDirect USB/Serial". After a short time it should time out with "The connection between your handheld computer and the desktop could not be established.....".

    If you do not see the above text the check:
    Preferences / Hotsync... (at the bottom right). Is the cable option set to Hotsync ?

    Btw: where are you ? you did not enter a location
  3.    #3  
    Yep...after pressing the button I will see: Connecting with the desktop using Direct USB/Serial

    Connection settings:



    Local HotSync

    The message I get:

    "The connection between your handheld and your computer and the desktop could not be established. Please check your setup and try again."

    I also didn't tell that my PC is connected to a LAN and that I am able to syncronize over the internet using the modem option. I found that out yesterday also on this forum.

    Local hotsyn will still not work....the PC doesn't react on pushing the Hotsync button on the cable.

    Hope you can give me some good advice.



    PS. I'm living in Holland by the way.
  4. #4  
    Too bad that you are not in Germany, my telephone calls are nocharge on sundays.

    Next question: Is Hotsync loaded ? You should see the Hotsync icon on the right hand side of the task bar.

    If Hotsync is not loaded, then start it. (and try to sync).

    If Hotsync is loaded then do right-click on the icon, in the upper section you should see a tick mark next to "Local USB". If not then click (left) on this item and try again.
  5.    #5  
    First of all, thank you very much for your help.

    No GSM charge would certainly be an advantage now, yes. Anyway, a local Hotsync is very much preferable because I would like to experiment with the big amount of software available for this brilliant device. OTA provisioning would be a little bit unreliable and expensive for those activities .

    My Hotsync mgr is very much availible.

    The procedure I followed now is:

    - Press the Hotsync icon in the Main menu

    - I see the Hotsync logo (with the local option and Direct USB/Serial selected)

    - Modem Sync Preference =Network
    - LANsync =Local Hotsync
    - Primary PC setup was filled in for modem/LAN Sync connection and is now empty
    - On the desktop: Local USB is untagged
    - in the Windows Device mgr.the HandspringUSB driver is available. I have reinstalled it and refered Windows to the driver in the Handspring drivers map.
    - I've restared the PC
    - softreset device

    Still no result...PC stays quiet as if there is no cable connected!

    Any more suggestions? I think we've almost tried everything.


    PS. My Hotsync Version on the Treo = 3.5. Palmdesktop version = 4.01 HotSync Mgr version = 3.1. HandspringUSB driver = (d:\winnt\system32\DRIVER\visorUSB.sys; fileversion 1.0.0) I am able to Syncronize over the internet! Could it be an outdated version of the USB Driver or again a broken cable?

    PS. I've also tried a custom connection with the Auto Detect and USB to PC options result

    Is it common that USB connections on the T180 could be unrelaible? I'm curious if I would have the same problem with a serial cable. If the Belgian repair service would have sent me one instead of a USB cable again... I would have known!
  6. #6  
    Upto now everything, except for one thing, seems to be correct.
    What OS are you using ?. On my Windows 2000 Professional the device manager does not show any Handspring device, therefor I can not select a device. But the device appears as soon as I press the Hotsync button, immediately before the sync starts, and disappears when the sync has been completed.
    Btw. The device is located directly under the computer (root) as "Handspring Handheld" with the USB list below this entry as "Handspring USB".

    I suggest you try the following:
    Unload (Exit) the Hotsync manager on the PC.
    Open device manager and enlarge the window so that you can see as much as possible. Do not select "Show hidden devices".
    Then do a scan for hardware changes (menu Action).

    One this is done find the entry for "Floppy Disk Drives". You should not see an next entry for "Handspring Handheld".
    Keep your eyes on the entry for "Floppy Disk Drives" while you press the hotsync button on the Treo cable.

    - Did anything happen on the Device Manager, did you see it being refreshed ?
    - Did an entry labelled "Handspring Handheld" appear below "Floppy disk drives" ?

    It you see the "Handspring Handheld" appear then the USB sync signal did arrive, if not then it might be a problem with the connector on the Treo.
  7.    #7  
    Hi there again.

    I've followed the whole procedure above. After deinstalling the Handspring device driver I rebooted the PC. Then I gave a soft reset to the device and tried to Sync it again. Unfortunately I didn't see anything happening in the device manager.

    I still don't understand why the is Treo responding on a button press on the cable while the PC stays quiet? Next to that the charger still works!

    May we conclude that the connector on the Treo is broken? Is this happening more often with the 180 models and what can I do to prevent this next time. In case it has been broken...why is this so volnerable? Are the old USB ports dangerous for these kind of devices?

    I'll send it to the repair service to get the connector plug fixed (still guarantee). Or would it be easy to fix it myself? It will not be the kind of repair like replacing a fuse I think.

    Thanks for giving me advice.


  8. #8  
    Hallo Thomas,

    I was out due to a problem with the hard disk on my workstation.

    The clear one point, the button on the USB cable does not connect to the PC, it is only connected to the Treo. The Treo wakes up when you push the button and in response activates the USB interface. This again causes the PC to react and activates the hotsync application.

    The symptoms you describe do point to the possibility that the USB interface on the Treo is defect. My advice is to call HS and request a replacement.

    PS. Did HS close the Amsterdam office ?

    Tot ziens (ja. noch een Kaaskop ;-)
  9.    #9  
    Maakt niet uit.

    Hartstikke bedankt voor je goed bedoelde hulp. You seem to know a lot about the technical details of this HS device. Let me be clear: the device is absolutely brilliant but I'm very unlucky with this USB problem.

    For Holland there is only the repair service of HS in Belgium. HS support is now located in the UK. We'll have to do it with that!

    Actually I have received a reply on a earlier mail but I don't think the suggestions make sense. I've tried so many things already.

    Dear Thomas Wesseling,

    Thank you for contacting Handspring Technical Support.

    Assuming you have already tried to troubleshoot by installing the latest
    version of Handspring's Palm Desktop software and using the Add/Remove
    Hardware Wizard, here are some additional troubleshooting steps for the
    "Unknown Device" issue:

    Situation #1: "Unknown Device" built in Device Manager after a HotSync

    If, in the course of troubleshooting, you see an Unknown Device listed in
    Device Manager, right click on it and select "Disable". Now uninstall and
    reinstall your Handspring software and attempt another HotSync operation.
    This may solve your problem immediately. If other crucial elements of your
    PC seemed to stop working after disabling the Unknown Device entry, you may
    re-enter Device Manager (in safe mode if need be), right click the Unknown
    Device and select "Enable". If Windows is working properly, this should
    restore whatever is required.

    If yet another Unknown Device is created after a synchronization attempt,
    you most likely have one of two issues:

    i. Your PC's USB controller is not fully functioning. Check Microsoft's
    Hardware Compatibility List at to see if your
    USB controller is well supported by your version of Windows. If not, upgrade
    your Windows OS or your hardware or both.
    ii. Your USB cradle is malfunctioning. Take your USB cradle over to another
    PC (hopefully a different model of PC) and try to perform a USB HotSync on
    that computer. If it works there, you can logically deduce that the first
    computer has a hardware problem.

    Situation #2: Handspring related entry permanently in Device Manager:
    1. Right-click on the "My Computer" icon and select Properties | Hardware
    tab | Device Manager button. (Alternate method: click on either of Control
    Panel | Administrative Tools | Computer Management | Device Manager.)

    2. Search for any entry labelled "Handspring Visor" or "Handspring USB",
    perhaps with a question mark beside them. Also click the + sign beside
    Universal Serial Bus Host Controller and search for the same two items.

    3. Ordinarily, the Handspring USB cradle should NOT show up as a device
    permanently listed anywhere within the Device Manager -- unless you view the
    Device Manager in the midst of a HotSync operation. If you see a Handspring
    related entry permanently in the Device Manager, delete it.

    4. Then try another HotSync operation. The proper drivers should be
    re-installed when the synchronization begins. Otherwise, you will have to
    uninstall and reinstall the Handspring software.

    Last resort solution:
    i. Use a serial cradle or IR HotSync instead of a USB cradle, or
    ii. Have your computer vendor reset your computer to the factory default
    settings for USB and install any helpful BIOS updates the vendor recommends.
    Then reinstall Handspring's software and USB cradle and try to synchronize

    If you ever have any other questions or issues, please do not hesitate to
    email us again, quoting the case number 3730164. This will assist us in
    tracking your case history, and for further troubleshooting.

    If you would like the latest updates or latest news concerning our products,
    please sign up for our free enewsletter at

    Troubleshooting articles, FAQ's and downloads can be accessed at

    Thank you,

    Handspring Technical Support


    Or would you think it will make sense to follow their suggestions? The other usb (printer) device is working OK so the USB port couldn't cause the problem.


    Thomas a.k.a kaaskop
  10. #10  
    My suggestion is to do what HS says, but only upto the first part with the unknown device.

    The second part you should ignore because the same symptom occurs on more then one machine. The only thing that might apply is if all machines have an older VIA chip set that is not supported by microsoft, but then nothing would work.

    Then the next step should be to inform HS that the Treo fails to communicate with more then one machine and request a replacement.
  11. #11  
    HS does not immediately inform you that Treo devices are so picky their USB connections. More than 80% of their suggestions in the website fails on Windows 2000 and USB Cradles. I followed all their suggestions and nothing works.

    When I called them the person that answered simply said, "Just get a serial cable. Your configuration would not work".
    Last edited by ronbo2000; 08/10/2003 at 02:05 AM.
  12.    #12  
    OK. Could be very true. But I'm curious if a serial cradle could solve the issue and makes it work again? Do you have experience with the serial cradle? What steps have you taken to resolve your issues.

    Thank you for your comments.

  13. #13  

    I followed all the steps suggested in the "Why can't I synchronize my handheld with my desktop computer?" topic. I eventually found my answer but I placed a call to customer support out of desperation, only to be told the same thing I already discovered.

    Anyway, read over the response by Chris from Handspring Technical Support in one of the responses in this thread. Check if your USB Controller is supported by your Windows OS version. Different OS has different compatibility levels with USB controllers, for example, if you have Win2K today and had your OS work with the USB then decided later to upgrade to WinXP, your USB may fail. Please check the for compatibility check.

    Anyway, serial cable sync cable works fine all the time. I was not able to re-activate my USB despite the instructions given by HS. My final findings was that the USB controller I have on my PC is not fully supported by the OS even though other USB devices may work, apparently the Handspring devices are for absolute compatility only.

    Good Luck!

  14.    #14  
    Ok. But my USB controller is working absolutely fine. I have two other devices on the USB port (like a printer) and I even tried an iPAQ device which is working fine. So the USB ports are not causing the problem.

    Thanks for your reply anyway.

  15.    #15  
    So in your case the USB cable is not working and a serial cable does? Then I will try a serial cable.


  16. #16  
    You missed my point. My USB is working with other devices. I have a hard drive which connects via USB and it has no problems.

    It is Handspring that is particular about compatibility. My Handspring USB used to work and it just stopped working all for no particular reason at all.


  17.    #17  
    Ok..but a serial cable should work? Because I haven't tried one yet (I can not buy it in the shops in Holland but only order via the internet so I have to be patient)...


  18. #18  
    Have you considered that the problem might be the USB cable itself? Maybe you can find someone else with a Treo, and borrow their cable to test.
  19.    #19  
    I have already got my USB cable replaced. I still have the same problem. Now I need to try a serial cable to be sure that the connector plug is (not) broken.

    Like I've said before...just need to be patient.

  20.    #20  
    I'm syncing again. The Handspring repair service in Belgium has send me a serial cable. Because the speaker also was broken I got a new device. I'm extremely happy again now.

Page 1 of 2 12 LastLast

Posting Permissions