Page 2 of 2 FirstFirst 12
Results 21 to 27 of 27
  1. #21  
    Originally posted by Dunc
    I haven't used Top Gun in about 6 months, but this past week I had an emergency and had to use it. Unfortunately I couldnt' get it to work. No matter what I try to connect to I get a "Cannot Create Socket" error. I tried uninstalling the app and reinstalling it but I keep getting the same thing on my 300. Has anyone seen this? Thanks,

    No, I haven't. And all your other TCP/IP applications are working? Have you tried Mocha Pocket Telnet instead?

    Have you tried disabling all your hacks and other OS-patching pieces of software?

    Top Gun requires a whole lot of support libraries -- is it possible that some other application installed a library with the same name? I know there are multiple different apps that use a "zlib.prc", for instance, and they can mess each other up (Top Gun doesn't use that particular one, though). This "flat namespace" aspect of the Palm OS is very unfortunate and an extremely archaic design, OS-wise.

    Of course I would have thought uninstalling and reinstalling would have taken care of such a problem. You could use a program like FileZ to ensure that all the support libraries are installed and are the expected versions.

    While I'm here, I should note that I edited this post of mine above just now, adding a note about an area where Top Gun's "tgtelnet" terminal type is far superior to Pocket Telnet's VT emulation, despite pcampbell's suggestion to the contrary, and I edited this post, noting that you need to use "M-x rename-uniquely" before you can open a second "M-x shell" session in Emacs (took me a bit to figure that out, so I wanted to share).
  2. #22  
    No, I haven't tried Mocha but I have determined that the current version of Top Gun is not compatible with Verichat 1.56b and PalmNet 2. When Top Gun was installed along with those two apps I was having issues in all of my TCPIP apps. Snappermail reported no available sockets. Verichat kept getting a 3G error and would try to reconnect to Vision. PalmNet wouldn't connect. Take Top Gun off, do a soft reset, and everything is back to normal. Similarily, take Verichat and PalmNet off and TopGun starts working again. I guess I'll have to try Mocha as I have become extremely reliant upon PalmNet and Verichat lately.

  3. #23  
    I tried Mocha Telnet... just before my phone broke last night. Anyways, I couldn't get it to connect to any of the servers that I need to connect to. Watching my own server's logs it appeared as though Mocha wasn't even attempting to connect. Any tricks to getting it work?

  4. #24  
    For some reason, even though I had told it to ssh rather than telnet, it was still trying to use port 23.
  5. #25  
    Yeah, the program actually instructs you that you need to manually do that, but it's very ambiguously worded. The checkbox says "SSH (use port 22)".

    Like many others, I'm sure, I first thought that meant that checking that box would cause *it* to automatically use port 22.

    Of course this all comes about because Mochasoft made Pocket Telnet able to connect to SSH servers on nonstandard ports, which is laudable, but they should have worded the checkbox text as something like "SSH (be sure to enter port 22 above)". Either that or made the Port field automatically change to 22 when you click the SSH checkbox to on (if that's possible with the Palm OS APIs).
  6. #26  
    I never got around to re-testing all the apps in my Palm OS Terminal Apps Buying Guide while I was on my Treo 600 -- only used TuSSH on it -- but now that I've moved to a 700p I have re-tested all the apps and updated the guide.
  7. #27  
    you know... pssh works well on the 650 (still)
Page 2 of 2 FirstFirst 12

Posting Permissions