Results 1 to 3 of 3
  1.    #1  

    I just change (RMA) my treo 270 due to a problem of battery. In fact my treo stop charging after 5 to 30s but it was still not fully charge. So HandSpring sent me a new one, perfect service in less than 5 days during Xmas period

    They changed it but i have still the same problem...; I connect it to power, 5s to 30s after the red diode change color to green... You can think the battery is full but you unpluged it try a phone call (10s) and then you have less than 70% of the battery indicator.

    Did someone experience the same problem?

    for example:
    When plugged to power (and green diode)
    Voltage 4207mV
    NoLoad 4216mV
    Load 305mV
    Percent 100%
    Avg Voltage 4163mV
    Avg Percent 100%

    When unplugged (and a 10s phone call)
    Voltage 3865mV
    NoLoad 3875mV
    Load 305mV
    Percent 66%
    Avg Voltage 3928mV
    Avg Percent 79%

    Thank for your help

  2. #2  
    This is a well documented Treo problem (search this forum for more detailed information) of the first shipments.

    I thought this issue was resolved with the latest units though.
    Did Handspring send you a reconditioned device?
    You must request from them to replace your device with a recently assembled unit (you will recognize them with they brighter, more defined screen), as I understand that this issue is now fixed.
  3.    #3  
    Yes they did send a recondition one I think due to the fact the treo was not in the oriinal box

    sorry but did not find any reference to this problem

    thank for your help, I did contact handspring in order to repalce it one more time.

Posting Permissions