Results 1 to 13 of 13
  1.    #1  

    I used the that was posted to add some ring tones to my Sprint Treo 300 now after doing a hard reset, two of the ringtones are still showing up in the phone app. any ideas?


  2. #2  
    use ringo. delete them with ringo's utility then use ringo's 'synchronize' function. if that doesn't work, email me and i will send you a copy of the midi_ring_tones.pdb file with nothing in it. this has happened to others.

    by the way, its not an issue with the tones, its a memory issue with the treo. i think ringo must be aware of it by now as it has come up many times with tones also.
    Change is a challenge to the adventurous, an opportunity to the alert, a threat to the insecure.
  3.    #3  
    okay i will try that. i did back up my midi_ring_tones.pdb and loaded an empty one and they are still there. but let me try ringo. i will let you know how that goes.

  4. #4  
    hope they were good ones, anyway! (just kidding, i was the one who posted them)
    Change is a challenge to the adventurous, an opportunity to the alert, a threat to the insecure.
  5.    #5  
    well this has me puzzled.
    the two i loaded were "hawaii 5-0" and "greatballstreo"
    from ringo i did "Clear Radio Ringtones"
    and then "Synchronize Ringtones" and they are still there.
  6. #6  
    I have the same problem and I haven't found a solution yet. I'm not sure how this all works, and I'm not sure the exact role the midi_ring_tones.pdb file plays. When I add a ringtone through Ringo it replaces the other two that seem to be stuck. So, the only time I see the two that are stuck is when I clear out the ones added by Ringo. I'm content with that for now, but it does bug me that I can't get the ringtone list back to normal.
  7. #7  
    I'm taking a guess at this (since I didn't write Ringo), but I think the way Ringo may work is this:

    [Heavy Assumptions here...]
    When Ringo is first installed (or thinks it is first being installed) if it doesn't see a backup of the system midi file (SavedSystemRingTones) , it creates one from the "System MIDI Sounds" file. Therefore, whatever MIDI tunes are in the file at that time becomes the "saved midi file". Then, if later you ask Ringo to restore the midi file, it uses it's backed up version. It may assume that it's saved version is a "clean" version, although "clean" may mean whatever MIDI tunes where avialable when it first created the backup.

    The reason I "assume" this ( I know, I know...), is that Ringo has a creator ID of EPRo, and there are other supporting files on the device with the same creator ID, one of which is "SavedSystemRingTones".

    Then again, maybe Ringo has some concept of what a clean "System MIDI Sounds" file contains (but I don't know how/why since that could change between devices or version of the OS).

    So, what I'm hinting at is that, depending on the situation in which Ringo is installed, it may require that you remove Ringo from your device and then re-install a "virgin" copy of the "System MIDI Sound" file. At that point, reinstalling Ringo would be fine and it would be better able to deal with adding and removing MIDI sounds or totally reverting back to the "virgin" set of sounds.

  8. #8  
    Not a bad theory. I'll see if I can go through the steps and get back a clean midi_ring_tones.pdb. Thanks!
  9. #9  
    I was told ringtones are saved in a separate memmory module that would make since that a hard reset doesnt clear it.
  10. #10  
    I have the same issue as well.

    I also can not get more than 2 tones to import into the system. I see doubles of all the normal system ones but when i sync or clear to try and add new tones i can not. (above with ringo)

    i also can not assign personal ring tones via the speed dial pages. the tones do not show up as they should.
    <b>The difficult is easy, the impossible takes time.</b>
  11. njchris's Avatar
    459 Posts
    Global Posts
    475 Global Posts
    Can anyone send me the default "Midi_Ring_Tones.PDB" and system ring tones files? Email is
  12. #12  
    *** BUMP ***

    New to Treo300 and already in trouble.

    I have installed Ringo and a collection of polyphonic ringtones. I added several to my personal collection and they play fine. But now I am unable to delete the first two on the list. I have tried RINGO's clear and syncronize. I've tried TC Ringer but the "stuck" rings don't show up in TC Ringer. I've tried updating the PROM on the radio in hopes that it would overwrite. I've restored the default System_MIDI_Sounds.pdb and System_Ring_Tones.pdb. I've even took my phone apart and disconnected the battery for 24 hours which obviously cleared everything else. No Dice.

    In desperation, I tried adding the same two ring tones to the radio AGAIN, and now one of the ringtones appears in my list 3 times in spite of Ringo showing nothing.

    HELP. Does anyone know how to purge the radio's flash memory (or whatever it uses that is not cleared by removing power)?
  13. jaak3's Avatar
    65 Posts
    Global Posts
    68 Global Posts
    It is (or was) well known that Ringo was unreliable on the Treo 300, which is why when you read through the old messages a lot of them recommend not to use Ringo, but to use TCRinger instead.

    Anyway, the Radio part of the Treo 300 is separate from the Palm side, which is why you can't hard reset it or let the batteries run out and expect it to be cleared.

    Scott Gruby wrote a utility to delete rogue ring tones from the Treo 300. You used to be able to get it by sending an email to If that doesn't work anymore, send me a private message and I'll email it to you.

Posting Permissions