Results 1 to 5 of 5
  1.    #1  
    Have you guys encountered this problem?

    I upgraded to GPRS version 1.1 and the treo crashes everytime i try to access the SIMphonebook or the SIM services apps. . .

    It says :

    MemoryMgr.c,Line:4340,NULL handle . . .

    I disconnected all hacks but i still get the same message. . . anyone out there with the same problem?
    Last edited by lancey; 10/08/2002 at 10:58 PM.
  2. #2  
    Do a backup of your data, then do a hard reset. Check to make sure your sim book and security are now working.

    Then, before restoring data, delete the files associated with the sim book from the backup folder.

    Somehow, the files saved from the previous version are not compatible with the new ROM version. It should work after that. I had exactly the same problem including a problem with my security app.
  3.    #3  

    Thanks a lot man. . . it worked !!!!
  4. #4  

    Kevin from Handspring here. I wanted to address your question about the memory error. This specific type of error is usually caused by a problem with a third party application, and can be solved by deleting the application. If it happens again you can find more information about the issue at this link:

    How do I avoid the error "Fatal Alert MemoryMgr.c, Line:4340, NULL handle"?

    I hope that helps.

    Best wishes,
    - - - - - - - - - - - - -
    Kevin Michaels
    - - - - - - - - - - - - -
    Check out what’s new at
  5.    #5  
    Hello Kevin,

    Thank you for responding.

    I did read your link. . . but in this case, it was really the SIMservices_enUS.prc and SIMPhonebook_enUS.prc (as well as Security_enUs.prc) and not a third party application. Tuen is right. Even if I made a hard reset and used another hotsync name before I upgraded to ver 1.1, the old files(the three mentioned above) restored themselves because i used the same hotsync name after the ver 1.1 installation.

    So. . . I just made a hard reset again with the new 1.1 installed and used another hotsync name and true enough, it was OK.

    I'm surprised that someone from handspring has tried to help me. Thank you for that. . . No offense but I don't know what's going on with your customer support. I e-mailed handspring about this problem and here is their reply. . .

    "Thank you for contacting Handspring Technical Support. We understand
    you are experiencing difficulties with fatal errors on your Treo since
    installed the GPRS upgrade .

    The Treo GPRS Upgrade 1.1 patch is not meant for download by North
    customers. We offer no support in case of any errors since this
    Installing this patch also voids your warranty.

    If you are not a North American customer please refer to for support.

    If you ever have any other questions or issues, please do not hesitate
    email us again, quoting the case number 3426531. This will assist us
    tracking your case history, and for further troubleshooting.

    If you would like the latest updates or latest news concerning our
    please sign up for our free enewsletter at

    Troubleshooting articles, FAQ's and downloads can be accessed at"

    Handspring did not even clarify if I had a North American carrier(which I don't) and besides I've been communicating with them because of another Problem i had.

    Sorry man. . . i love the treo 270 but i sure wish customer support would get its act together

Posting Permissions