My relatively new Treo180 had worked very well as a telephone roaming around the USA and Europe. But I am now in Hong Kong (which has GSM 900 like Europe) and cannot get connected to the phone networks.

The unit was purchased in the USA and worked fine there, but I have been unable to make a connection in Hong Kong. I have tried my USA SIM card, a Hong Kong Orange pre-paid SIM card and a China Mobile SIM card. All of these work/connect in Hong Kong on the GSM 900 band in my other mobile phone, but my Treo doesn't seem to recognize them. In fact, my Treo doesn't really seem to look for the network the way it did when I was in the USA or in Europe. It gives me no dialogue box showing that it is searching for the network (ie, dancing Handspring X logo).
It always says it is 'Network Search' but never finds one. Also, under options I am unable to make it search for particular networks for some reason the way I could in the USA or Europe. The machine says 'Wireless Mode must be on for at least 30 seconds...' even tho that mode had been on for several minutes or longer.

In short, the problem is with the phone not the networks.

I have 'soft,' 'system' and 'hard' reset - all to no avail.

Do you know what the problem may be? I have seen discussion boards talk about a 'ResetRadio.prc & SdrvDirectRadio.prc' program that sounds like it might work.

Please help me on this, as I really need my Treo to work as a telephone.