Results 1 to 2 of 2
  1.    #1  
    This problem seem to happen sporatically. Sometimes when I try to make a call, instead of the Speakerphone Button appearing on my screen all I get is the Hold, Dial Pad, and Mute buttons. When this happens it places the call and I can hear the person on the other end but they can not hear me. This also happens if someone tries to call me, I can answer the phone but they can't hear me. I have tried to pull the battery to reset the phone, as well as turning off and then on the phone. Neither seems to work. Eventually if I just leave the phone alone for a while it seems to fix itself. This is getting very frustrating. Does anyone have an idea as to why this is happening?
  2. #2  
    It sounds to me as if your earphone jack is damaged. This happened to my 680 as well. Try putting some lubricating fluid on your earphone jack and rapidly push it in & pull it out. This seems to have worked for some with this problem. The Treo thinks your earphone is inserted, probably because something locked up inside, and would not show you your speakerphone option, because, with an earphone inserted, there wouldn't be any. The earphone jack is the weakest place in the 680. Better to use a bluetooth earphone & not deal with the jack.

Posting Permissions