Results 1 to 5 of 5
  1.    #1  
    Recently on my 680 (AT&T), the phone started slowing down. Now, as of a couple of days ago, my buttons stopped working. (The touchscreen is still fine). Like I can answer a call through the touchscreen, but I can't disconnect using the red button. Some other details...when I call my voicemail and push a number (i.e. 7 to delete the message), the number shows up in the screen but doesn't register on the voicemail. My center button still works, and somehow i can still unlock the phone, but the directional pad and the all the other buttons don't. Can anyone offer any help? I'm thinking I should just try to get it repaired. Any info would be great!
  2. #2  
    I had something like your prob before, what happened was ... I tested out a friend's 650. My GPS cradel was readjusted for the unit, and a few days later, I placed my 680 back. Didn't realize it, unit I tried to use the hard keys (phone,cal, mail & home) and non work ..., execpt for the red power button.

    I figured out it was the side key (not the vols) was pushed in toooooooooo far. Took the housing off and prob was fixed.
  3. #3  
    Actually, I just had the same exact thing happen yesterday. All of a sudden, none of my buttons would work. I did several resets by removing the battery, but nothing seemed to fix the problem. My touchscreen worked with the stylus, but the d-pad and the buttons simply refused to respond. I was strongly considering doing a hard reset to wipe everything off the phone (thinking it was maybe some software/memory leak), but after doing a lot of random button mashing, suddenly everything started working, and have had no problems since. It may have just been a stuck button, as E2EK1EL suggested. I'm just glad that the phone is now working again...*phew*!
  4.    #4  
    Thanks guys. I messed with the push-to-talk button a few (hundred) times and it finally popped free. Phone works great again (except it's still as slow as any other 680...). I appreciate the help!!
  5. #5  
    Holy ****! Just had this problem. Out of DEEP right field.

    It was my "N" key that was stuck. Almost had a coronary! Gotta set the alarm, need to be up in 4 hours, couldn't get the phone to do anything.

    Thanks for the quick fix......

Posting Permissions