I have been a treo user for several years. Have had a custom rom for almost a year with no major problems. I use my treo 650 for work, to save all calls, appointments, contacts... you know...

Well this morning I get a text message and I ignore it for a moment. Then I go to check it and press the red power button and the keyguard pops up but I cant unlock the phone... Center key wont work the keygaurd..

So the keygaurd times out, then I press the red power button again but this time it takes about 5 seconds for the screen to turn on. I try to press center key but again keygaurd wont unlock and screen goes blank..

I did this a few times then I opened the back and hit the reset button..

Now I am in a continuous loop that consists of.. well this..

I power the phone on and get the palm screen with the loading bar at the bottom and then as soon as its done the screen turns white and there is a black line across the top, one or two pixels wide, that is flashing along with the keypad lights at 1 second intervals.

I tried warm reset,, holding up while reseting.. same loop
I tried hard reset,, hoding power button and reset.. same loop.
Ok now I do a Zero out reset,, holding up/power/hotsync and reset.. lol WOW

I still have the loop.

I then use romtool which loads fine and finds the phone, so I upload the stock ROM and try it,, NOTHING, same loop.
I dont know where to go from here... is there something else I can do with the romtool?
Someone mentioned to me that the flashing might mean debugg mode?