Results 1 to 19 of 19
  1.    #1  
    Recently my Sprint Treo 755P got wet. Now, whenever I have the SD card in place and boot up the phone, I get a screen asking if I would like to "Update ROM Image?"

    If I choose No or if I don't have the card in place, then it immediately goes to a screen with Red, green, blue and white squares in a checkerboard pattern with "0.19" listed in small blue letters at the top and stays that way.

    I've downloaded the 1.07 Updater from Palm's website, and loaded it to the card, but when I choose to update the ROM image, it diplays "Checking SD card..." and eventually goes to "ROM Image not found on SD card" and then back to the screen with the multi-colored checkerboard.

    Is there anyone that knows where I can download a ROM image file for this? Or a wat to create one from another 755P? I have another 755P phone on hand to use to gather files.
  2. #2  
    First question: is the phone completely dry?
  3.    #3  
    AS far as I can tell, yes it is.
  4. #4  
    I am having the EXACT same issue. It either goes through hot sync repeatedly or gets the red/blue/green update rom screen.

    I found that if I take out the battery and hold down the up arrow while I put it in that I can get it to look like it's loading correctly, but then it goes into the hot sync.

    If I try to hard reset by holding down the red power button while I insert the battery it just goes to the red/blue/green screen.

    The only good thing is that I was able to hot sync and back up my info while it was doing the crazy hot sync thing. All my data backed up fine.

    If anyone knows a way out of this, please post it!

    Good luck to you drumana!
  5. #5  
    I had the exact same issue a month ago. I gave my phone to my 14-month old daughter to keep her from screaming and she bit the power button.

    Turns out, the power button became "permanently" depressed and when your treo starts up with the phone button on, that's code for "update ROM".

    I played with the button for a while and managed to get it to not be depressed. For a quick solution (to at least get your phone up and going), hold down another button on boot up and at least it will come up to a normal screen. However, from there, the power button will still be on so it may try to turn the radio on/off.
  6. #6  
    I went to the Sprint store today and told them the issue my phone was having...repeatedly trying to hot sync or the red/blue/screen and they said that 99% of the time when it does both of those things that it is liquid damage...sure enough, they took my phone apart and it had liquid in it...who knows from where!

    Anyway, they said they don't replace phones with liquid damage but after a long discussion they finally agreed and replaced the phone...thank goodness!

    Hope that bad news helps someone...
  7. #7  
    I too have had the same issue...with three phones. In only one case did the offending phone show the multi-colored screen of death after getting wet. I have no clue why it happened in the other instances. Having gone through this with 3 phones, I have learned the following:

    1. If your phone continually tries to Hot Sync itself, removing the battery and reinserting it will lead to the screen of death.

    2. If you take out the battery and leave the phone untouched for about 24 hours and then re-insert the battery, the phone will boot up properly with the auto Hot Sync loop and screen of death gone, if only for a short while - i.e. the phone appears to reset itself with no data loss.

    3. I thought that I was the only one who experienced these two issues so I was convinced that there was a problem in my Palm files that was corrupting my 755. Good to know I am not alone with these hassels. 3G
    I-Phone anyone??
  8. #8  
    I took my phone to a local Sprint store and they were able to correct the problem. No more red, blue, green and white rectangles and the inexplicable "0.19." Also, there was no wetness (Sprint way of declining ins. coverage no doubt) or power button problem, leading me to believe that something else causes the problem.

    For those of us who have incurred this issue, do you have 1. Snappermail and/or 2. Bike or Die installed on your Treo? Those are the only 3rd party apps that I run. I'm wondering if either of them cause this issue.
  9. #9  
    :^/ My Tré0 755p (Sprint) is experiencing just this trouble.

    I had Resco Explorer installed and registered. Through it, I had created an Bluetooth connection to my PC and had mounted my PC's D:\drive as my BT connection. After browsing for a while, I began copying .gp3 files from PC to Tréo and viewing them.

    It worked just great until one of them never finished copying. After several minutes of the Tréo not responding to key presses or screen taps, I removed the battery for a soft reset.

    It never worked again.

    I can get to the multi-colored screen. (The bootloader,) and can get the Tréo to try to update the ROM from files on the SD card. The trouble is that I don't know where to get the required ROM file, nor where to put them on the SD card.

    Any suggestions welcome....
  10. #10  
    You could fix it with ebag333's BL+ROM method (see the 700wx forums), but it will need some patching/overwriting of files.
    6b 6f 63 6f 6d 61 6e 20 6f 66 20 63 64 6d 61 2d 64 65 76 2d 74 65 61 6d
  11. #11  
    This problem happened to me this morning - got my phone wet. Booted up to that ROM message and RED/GREEN screen of death. After giving it an hour to dry out, I can boot up - only to get the continues Hot Sync issue. After 4 more hours, the Treo boots up normal and only tries to Hot Sync about every 15 minutes. I hope the more it dries (internally), the more this problem will go away.
  12. #12  
    Follow up - 4 days later.

    The last 2 days have been great - no red/blue/green screen and only a few times did it try to hotsync on it's own. But now today - without anything happening to my Treo - it's doing it again. the 0.19 ROM red/blue/green screen of death.
    Is it still wet? I haven't even had it outside today. It is almost as if the problem is reversing itself today. I woke up and the Treo was attempting to Hot Sync itself about once every 5-10 minutes. Now 6 hours later, it's dead.
    Any fixes?
  13. #13  
    Did you dry it out for at least a day with a dessicator of some variety (like uncooked rice)?
  14. #14  
    Just popped the phone and battery (separate) in a can of uncooked rice. I'll report back Friday morning....
  15. #15  
    Well, after a couple days buried in rice - still nothing. Can't be that wet. Time to start shopping. With nothing to lose, I'll leave it buried in the rice another week and see if it matters.....
  16. #16  
    To get to the boatloader screen press Volume-Up + Camera and then insert the battery. It will check if an inserted MiniSD card has a rom file, and if not, give an error message. Otherwise it boots into the checkboard screen with the number 19 on the top center of the screen.

    If you water-damaged a phone, you probably have a short on those two buttons, and even when dried to be shorted from the rust crustings.

    If someone has a rom for a 755p, please give me a holler.
  17. #17  
    I have the exact same issue, but my phone is a refurb'd 755p, which Palm sent me as an exchange for a warranty repair on my old 755p.

    At first, it did the endless loop of the Hotsync mode.

    Then, when I tried a hard reset, it now shows the colored pattern with blue, green, red colors, with 0.22 at the top.

    Sadly, I can't get into Palm's chat support site (it seems to be down), so I'll try my luck at the Sprint store.
  18. techsign's Avatar
    9 Posts
    Global Posts
    17 Global Posts
    Quote Originally Posted by kocoman View Post
    You could fix it with ebag333's BL+ROM method (see the 700wx forums), but it will need some patching/overwriting of files.
    Do you happen to know what the filename is and the location on the sd card that the phone is expecting the file at? I have tried to flash with that method using the default Treo 755p rom name (TorinoMR-Release-VRZW-Dev-EnSP.rom), the 755p rom zip (, the 700w filename (NapaBoth.nb0), and the 750 filename (CheeDIAG.nbh).

    All these methods have resulted in the phone saying that no rom file was found.
  19. techsign's Avatar
    9 Posts
    Global Posts
    17 Global Posts
    Try pulling the battery and holding UP while you replace the battery. Hold UP until the phone finishes booting. It may help.

Posting Permissions