Results 1 to 6 of 6
  1.    #1  
    eBay has some generic 4gb SD cards from Hong Kong for dirt cheap shipped. I don't see how I can lose.

    Does anyone know for sure that these do or do not work in a treo 680?
  2.    #2  
    Update: Need help.

    Just got the card in today. I got an 8 GB card.

    I inserted the card into the Treo and it asked me if I wanted to format it. I clicked yes. Took a minute or so to format, but when it was finished the T680 doesn't see it. It says that there isn't a card inserted. When I take it out and put it back in, it beeps and goes to the card page, but when I go to card info it says the card isn't inserted.

    I plugged it into the card reader on my laptop and formatted it there. Even though it is an 8 GB card, the laptop formatted it as a 4 GB card. Fishy?

    After formatting it on the laptop, it still doesn't show up on the T680.

  3.    #3  

    When I am in "Card Info" and take the card out and put it back in, it recognizes it and gives me all the card info. However, when I click out of "card info", it unmounts(?), and I have to take the card out and put it back in.
  4.    #4  

    Tried a hard reset and it still acts the same.
  5. #5  
    Try an app like card keeper(sp) or the like and see if that solves your problem.
  6.    #6  
    Thanks for the reply, but it went back to Hong Kong today.

    The seller blamed it on the factory, but it was a 4GB card instead of an 8.

Posting Permissions