Results 1 to 3 of 3
  1.    #1  
    I have a Cingular branded 680

    Firmware: R01.91
    Software: Treo680-2.11-ATT
    CarrierDB: 510
    Hardware: A

    Updated to 2.11 when it was released. Have been using a Roshan SIM (Afghan) in the unit since August 07 without issue. Went home for a bit in Feb and used my Cingular SIM without issues. Came back over this way and the Roshan SIM wouldn't work. Thought maybe it had been damaged during the trip (was in the backpack) so put in the Cingular SIM. Both SIMs cause the 680 to say "SIM not allowed" and then goes to the "No Service - SOS only" prompt.

    Soft reset is of no help, hard reset is of no help.

    Every SIM I've attempted has been verified good in at least 2 other phones. Tried the eraser on the contacts bit, tried the tape on the back of the SIM bit, no change.

    I'm about to try the C4 bit and just move to Blackberry when I get home. But I kind of need the phone for quick calls home when I can.....

    Anyone have any clue what might be the issue? Or explain to me how the SIM gets vetted in the phone? I did notice that all thats shown when the phone is on is one network (there are 2 here) and instead of the typical name it's just numbers.....

  2. #2  
    At some point you may have to admit you have a hardware problem with the SIM reader. That's very unusual and I haven't heard on anyone having that problem before.
    If it is a hardware problem, you'll have to send it in for repair, very sorry!
  3.    #3  
    I may have found a fix. I forced a restore from NVBackup from before the latest update (2.11). I'm not too knowledgeable on what exactly NVBackup actual saves so I'm not sure if the update was the problem, but the phone recognized the SIM the first time.....

    I'm going to do the hotsync bit when I can turn the PC on and see what happens (Custom hotsync). Hopefully I can get my data back on without causing the same issue again??

Posting Permissions