Results 1 to 14 of 14
  1. GSMacLean's Avatar
    57 Posts
    Global Posts
    68 Global Posts
    Due to a huge screw-up Sprint made with my account that took them weeks to fix (which I will write about another day), they ended up swapping out my beloved 650 for a brand new 755P (no charge, no contract extension, nothing).

    Fine, great, I get faster Internet, all my old software runs, better camera, no antenna.

    But then I try to run the one app I use more than anything - my TomTom Navigator 6 GPS - and no go. It runs, but does not find the GPS (standard "Palm" silver GPS that comes with Navigator 6).

    I spent hours on the web researching. I am running the 1.07 Sprint firmware. I found references to the 680 "patch" for Navigator 6 from Palm and downloaded it - only to find that I am already running it (it was part of the 1.03 upgrade I put into my 650 a few months ago). I tried warm booting, soft booting, pulling the battery, deleting the GPS registration, nothing works.

    Here's what happens:

    - Start up Navigator. It looks for, finds and connects with the GPS.
    - Shortly thereafter, it comes back and does one of the following:

    a) "No GPS Signal"
    b) "GPS Signal lost xx seconds ago" (and continues counting the seconds, never actually acquiring a signal)
    c) Acquires a fix, updates the position on the map, then switches to "GPS Signal lost xx seconds ago" and never acquires another fix
    d) Acquires a GPS signal and works

    In the testing I've done, a) happens about 75% of the time, b) happens about 20% of the time, c) happens about 4% of the time and once in a very VERY rare while, d) happens and it works. However, when it is working, it is EXTREMELY slow - with one screen update every 2-3 seconds (used to be one update every 0.5 to 1 second on my 650).

    If I try to enable TomTom Traffic, which worked perfectly on my 650, it either fails, locks up the phone, or reboots.

    I *know* the GPS hardware, Bluetooth and GPS driver portion of the phone are working perfectly. I downloaded LapLogger GPS from - this free software just connects to your GPS and spits out raw data showing your position, altitude, speed, etc. It works perfectly, every time, never fails. So obviously the problem is with the TomTom software.

    Talking to TomTom is pointless, they just answer with a canned email that Navigator 6 is not supported on the 755P.

    I am super frustrated by this. I use this GPS application ALL THE TIME, and now I can't use it at all. I see multiple messages on here from people who have gotten Navigator 6 to work on their 755P. What's the secret?
  2. GSMacLean's Avatar
    57 Posts
    Global Posts
    68 Global Posts
    I'm wondering if the SD card I'm using has anything to do with it. I'm using a 4 GB Patriot Mini-SD card. What are other people using that have no problem with TomTom on their 755p?
  3. #3  
    I do not have an answer for you but I do have some info and suggestions.
    I did have TomTom 6 working perfectly fine on my 755p for many months. I do not use it anymore but when I did I rarely had problems with it. Sometimes when I did have problems, I would have to turn the receiver off and then back on again. Which receiver do you have? Is it the one that is silver/black and says Palm on the front?
    Have you tried installing the "Navigator" application to your internal memory rather than trying to run it from your card? This is how I ran it with my Treo. I DID have all the other folders installed onto an SanDisk 4GB Micro SD with mini SD adapter. Just some thoughts.
  4. GSMacLean's Avatar
    57 Posts
    Global Posts
    68 Global Posts
    I have tried turning the GPS receiver on and off, with no effect - it doesn't change how well it works.

    The receiver I have is the one pictured in this photo:

    The Navigator application copies itself to the internal memory the first time you run it off the card if it is not already there. I suspect it then always runs off the internal version (even if you start the one on the card) for speed purposes. I've tried running both versions, and it seems to work the same way on both.

    What annoys me is that on Palm's own web site store here, they advertise and sell Navigator 6 as an "accessory" for your Palm 755P, when it doesn't work and isn't supported.
  5. #5  
    I know it doesn't help, but I can confirm that it did fully work on my 755p. I used it probably 30 to 40 different times and only had problems about 4 or 5 times. Those problems were the gps receiver losing signal (had to reset power) and the Treo reseting itself.
    The only other thing I can think to try if you don't get any answers here, is to try TomTom's discussion forum. It's not nearly as responsive as this forum, but can be helpful at times.
  6. stbxxl's Avatar
    513 Posts
    Global Posts
    563 Global Posts
    I also can confirm that TomTom works very nice with my Treo 755p. I use version 6.03 (Treo 680 update from Palm's web page) with the ROM version 1.07 for Sprint. The miniSDHC card is a Kingston 4 GB class 4. Before that I used a 2 GB miniSD card from Transcend. Both work just fine. The GPS receiver I'm using is the Freedom Mini GPS Receiver. A very nice GPS unit BTW.

    As other people have posted already it helps to turn off and on the GPS unit if TomTom has problems connecting to it. I also found that sometimes it was helpful to first start another GPS program, connect to the GPS unit, exit this program and then start TomTom. Usually it connected to the GPS unit quite nicely after this procedure. Although I have to say that after the ROM update for my Treo 755p this is not necessary anymore. Programs I used successfully to "help TomTom" are either cotogps 1.6.0 or Navegador 2.0b1. Both are free and good GPS tools to have anyway.

    I do have all TomTom files on the SD card with the exception of start.prc which resides in the Treo 755p's RAM. I deleted the file Navstart.prc from the SD card. It is not needed. Did you try running TomTom on a clean Treo? Make a complete backup via NVBackup (version 1.21 is the latest and does a 100% restore in my experience) and then install TomTom6 (i.e. install start.prc into the RAM) after a hard reset. This way you can find out whether some other program you may be using is the culprit.

    Hope this helps somehow.

    Last edited by STBXXL; 03/21/2008 at 05:58 PM.
  7. #7  
    For the Larger cards you have to reformat in your home computer/laptop using the command prompt screen. I also had this problem and was geting one screen refresh every 2 seconds and after i reformatted my cards as explained in this thread:

    It went to 2 screen refreshes every second. I did this to a adata 8gb sdhc in my 700p and a 4gb sandisk micro sd in my wifes Centro.

    Worked well try it.

    I also have an issue where sometimes i wont get a gps signal till a couple of minutes of driving and will loose the signal but I think thats more related to me using seidios gps receiver/cradle and it being mounted kinda low on the dash.(using the acvent attachment)
  8. GSMacLean's Avatar
    57 Posts
    Global Posts
    68 Global Posts
    Yes! I was on the verge of buying a new GPS receiver to try and get this working, and your suggestion has fixed everything!

    I had a 4GB Patriot Mini-SD card in my Treo. I had formatted it in Windows, using the default parameters. Doing so had caused it to format the card as FAT32 with 4K clusters. This was crippling TomTom Navigator 6.

    As mentioned in the thread above, I reformatted the card using 16K clusters:

    C:\>format j: /FS:FAT32 /a:16K

    (after first backing up the card contents to my hard drive). After reformatting, I copied the card contents back onto the card, stuck it in my 755P, booted up TomTom, and hey presto - everything is working perfectly, no delays, no problems connecting to the GPS, nothing. It all just works!

    Well, almost. When I tell it to enable TomTom Traffic, it hangs for a minute, then just stops - it's as if it's working normally, but the display never changes after that. I guess I'll just not use TomTom Traffic anymore.

    Thanks to everyone here who was so helpful!
  9. #9  
    My TomTom 6(with the newest maps)& 755p work perfect. I do have the card on FAT32, Navigator on RAM & I have the Treo 680 patch on it, which you can find here in TC.
    "A man who drinks only water, has something to hide to his fellow man."

    My beer blogs:

    Rev. Rhino on Flickr

    Rev. Rhino on Twitter
  10. GSMacLean's Avatar
    57 Posts
    Global Posts
    68 Global Posts
    It's not enough to have the card on FAT32 - if the cluster size it was formatted with is not optimal, Navigator 6 will crawl, and you will have the problems I have described here.

    Here's what was quoted, and what worked for me:

    Very important is the cluster size of your card. You will get the best results with the following cluster sizes. Use the DOS box for formatting your card. I`m using a Transcend 4 GB / 150x with best results (16K), even with big Western Europe map.

    Less than 4 GB (FAT16):
    format X: /FS:FAT /A:32K

    4 GB and more (FAT32):
    format X: /FS:FAT32 /A:16K

    "X" is the drive letter.
  11. #11  
    Do you think these formatting guidelines would apply with the Garmin Software as well?
  12. GSMacLean's Avatar
    57 Posts
    Global Posts
    68 Global Posts
    Quote Originally Posted by bjbarnes View Post
    Do you think these formatting guidelines would apply with the Garmin Software as well?
    I would not be surprised at all - the GPS software requires fairly rapid access to its data files, and if the cluster size is inefficient, it's going to slow things down. It certainly can't hurt to try.
  13. GSMacLean's Avatar
    57 Posts
    Global Posts
    68 Global Posts
    Some other things I have found out about TomTom Navigator 6 and Treos, over the course of talking to Palm corporate support the past few days:

    There are four different SKU's for Palm's GPS kits for Treos (the SKU is on a label on the side of the box that the hardware/software came in).

    3229NA (works with 650 and 700w only)
    3263NA (works with 650, 700w, 700p)
    3301NA (works with 650, 680, 700w, 700wx, 700p, 750, 755p)
    3380NA (Garmin software, works with 680, 700w, 700wx, 700p 750, 755p, Centro)

    From what I was able to glean:

    3229NA works only with the 650 and 700w, and includes a different (older) GPS receiver.

    3263NA, 3301NA and 3380NA all include the same GPS receiver. The only difference between the packages is the software versions and the type of SD card included.

    The 3380NA includes Garmin software, so I won't include it in this analysis.

    While Palm shows the 3263NA as not being compatible with the 755P, it will work perfectly if you apply the patch for the 680 found here:

    Palm's internal support knowledge base tells them that only the 3301NA comes with Navigator 6, and that the 3263NA and 3229NA come with Navigator 5. This is incorrect. They all come with Navigator 6.
  14. GSMacLean's Avatar
    57 Posts
    Global Posts
    68 Global Posts
    One other thing I found out about Palm third-level technical support yesterday: They use this forum as a reference tool when trying to solve problems.

Posting Permissions