Results 1 to 13 of 13
  1.    #1  
    Roughly a month ago I tried updating a Sprint 700p with the official Palm 1.10 firmware and the update went awry. I'm still not sure what happened, but now it continually reboots through the "Access Powered" screen, the stylus setup screen, the Sprint "phone active" logo, the Palm logo, then back to "Access Powered". When I do a System Reset, the phone goes off and the PDA portion is usable. When I re-enable the phone, it reboots again.

    I worked through Kocoman's instructions at, to try reflashing the Sprint firmware manually, but kept getting checksum errors when running the Sprint RomUpdater. I hard reset the 700p, tried a different SD card, and tried re-copying the software and shuffling it to different directories, but nothing helped.

    I went looking for other fixes and recently found the excellent "700p to 755" thread here...but installing the 755 firmware fails, too, with similar checksum errors. (I'd also downloaded another 700p Updater zip file from Palm to try another copy of RomUpdater.)

    What's more bewildering is the other error I'm seeing, which is the same thing I got from my first manual attempts, and from the official Sprint updater attempts, too:

    "CheckLowRiderDeviceVersion: does not start with part type set to dulPartMSysLow"

    What does this mean? Could the SD slot be damaged? Is there a programs I could use to test it? Does the RomUpdater program rely on any files in the Rom? That is, if something is screwy in the existing Rom, could that mess with RomUpdater? Is there a method to flash the Treo Rom that doesn't involve using RomUpdater? Everything worked fine until I tried flashing 1.10.

    Does anyone have suggestions? I'm getting frustrated, but still think there must be a fix somewhere... Thanks!
  2.    #2  
    If I

    1) Do a hard reset, which causes it to spontaneously reboot
    2) Do a system reset, which turns the phone off and stabilizes things
    3) Immediately type ##ERR# on the phone

    I get the error

    HTC6500StateTelephonyHandler.cp, Line:466, HTCInterface versions do NOT match -51 instead of 24

    Where would the Treo be pulling these version numbers, and in what part of the Rom are they located? Maybe fixing this portion of the Rom is my best bet?
  3.    #3  
    Hehe, replying to myself again.

    With a little desperation, I tried the 1.10 Palm updater tool again...and noticed the flash process was different than before. Hadn't tried it in weeks, but it was taking quite a bit longer this time. Now the phone no longer reboots, but I'm stuck in "Network Search" and most of the ## commands don't work because the phone isn't completely on. (BTW, could the fact that this phone isn't live with Sprint be interfering with the updates? I've been using a backup device since the flash first failed. I doubt it, but thought I'd still mention that.) A web search suggests I reinstall or tweak the PRL, but doesn't give many specifics. Could I use the "Update PRL" option in the CDFMAFirmwareUpdater's Debug menu? Or perhaps run the DefaultPRL.prc program directly? I feel like I've made a little progress and don't want to jinx anything...
  4.    #4  
    Replying again...

    I found some PRL instructions at but the comments I've seen from others suggest updating the PRL manually shouldn't be so terse. I found a nice PRL repository at, but am unclear how to apply them. Must I hack the CDMAFirmwareUpdater.prc file (or an exported NVRam file?), or can I use its higher-level functions to write a PRL file to the phone directly? What is the use of the defaultPRL.prc in the Sprint updater? Is there a way to convert the raw PRL files on that site to Palm .prc files? Sorry, so many questions yet!
  5. #5  
    Do you have a screenshoots of the checksum error?

    maybe the md5 of the and is wrong
    6b 6f 63 6f 6d 61 6e 20 6f 66 20 63 64 6d 61 2d 64 65 76 2d 74 65 61 6d
  6.    #6  
    I can make a screen shot. That's not a problem, but I'll have to do so later today. In case it's useful, with the phone stuck on "Network Search", ##ERR# now gives me

    CDMFirmwareUpdater.c, Line:2111, Wrong response received

    in case that helps.

    I wouldn't think it's a problem with the checksum on your 755 Rom archive because a) other people have apparently done it without problems, and b) I get similar errors when flashing the Sprint 1.10 firmware with a homemade archive.
  7.    #7  
    Okay, here is the complete transaction of the failed 700p->755 session, although I still question how useful it is. Not a screen shot, since Hotsync still works:

    Welcome to the Device Updater...
    ROM Build: 44
    Built: Feb 08 2007 09:41:18

    SD Card VolRefNum: 0x0002
    Board ID: VENT
    HW Rev: dvt


    CheckLowRiderDeviceVersion : does not start with part type set to dulPartMSysLow
    ROM image directory found on card, installing from there
    Preparing to update Ventura.
    Verifying the image files...
    Validating /ROM/ventura-ipl-dvt ...OK!
    Validating /ROM/ventura-spl ...OK!
    Validating /ROM/ventura-bl ...OK!
    Validating /ROM/ ...ERROR!
    ERROR: Ventura image files corrupt or missing.
    ERROR: Aborting update.
    Error (0x0012): Error calculating the MD5 Checksum

    I'm still intensely curious about the "CheckLowRiderDeviceVersion" error.
  8. #8  
    Huh?? Isn't Lowrider the code name for Treo 680, which is a GSM phone? How come it shows up in a ROM updater for 700p (code name ventura), which is a CDMA?
  9.    #9  
    Beats me. But I know I was getting that error long before I started hacking anything, so it was nothing I did. Now I just have to figure out how to get rid of it.
  10.    #10  
    When I do a ##786#, the phone tries to turn on (I see the Sprint screen and hear the chime), and then see three dialog windows:

    NV Read Failed: Cannot retrieve NV item Phone Life Timer from the modem

    NV Read Failed: Cannot retrieve NV item Data Life Timer from the modem

    NV Read Failed: Cannot retrieve NV item None of the fields can be initialized from the modem. RTN form will quit.

    Or perhaps this is normal, since the phone is stuck trying to turn on?
  11. #11  
    i ran into the exact same thing last week, Are you doing this on a clean card? I was but i had the ROM in a sub directory or something like that . i just kept moving it till it took. Can't remember exactly now. If i think of it i will post back, use resco explorer or file z to look at the card and where and what order it's in.
  12. #12  
    Hello I have problems with a Sprint 755p and a 700p as showing the Network Search... T (red colored) wording on the top left part of the screen. I have read through a lot of your posts and the programs I install on the phone via the SD card, when I click, it just says please wait and then goes back to the program icon as before I clicked it.
    I've try to reply to your email (I think), but it got sent back to sender. here is my reply, hope you can see it or help you in someway.

    Hi I think its a PRL problem. Have you used nverase in the past to erase the ESN, restored the ESN but forgot to reflash in the PRL? If you go to ##DEBUG#, the 3rd line would say "System Determination State"

    The T just means TTY mode is on. but I think you know that already.

    Can you see your phone's info in the "phone info" (ie: your phone#, ESN, PRL#, etc) or are they blank? sometimes with a corrupted NV or bad NV the phone radio would be OFF, but it would still say 'network search'

    I had this problem in the past but since it was a almost half a year ago I might have forgotten.
    6b 6f 63 6f 6d 61 6e 20 6f 66 20 63 64 6d 61 2d 64 65 76 2d 74 65 61 6d
  13.    #13  
    Thanks for the replies! Kocoman, I don't believe that quote was from me.

    1) ##debug# doesn't work because the phone/radio needs to be completely on

    2) If nverase is a standalone program, then absolutely not. I didn't start playing with non-Sprint tools until the phone failed. I did try exporting NVRam back when I began reading your Telus -> Sprint article from June 2007, but that's it.

    3) The Phone Number, PCS Vision Username, ESN, PRL, etc. fields in Phone Info are all blank...but I'm thinking this is normal when the phone is turned off (or not completely on)? The phone is also not currently active with Sprint.

    4) I've tried two different SD Cards, and have formatted each many times.

    From what you say, it seems to be a corrupted NVRam. So is there a way to fix this?

Posting Permissions