Results 1 to 10 of 10
  1.    #1  
    So, my 6gb microsd card has been fine till now. Suddenly my Centro is unable to see it. I have to do a hard reset and then everything is ok. I have tried ejecting the card, soft resets and warm.
    This is the second time this has happened.

    After the reset everything seems to be fine.

    thoughts anyone?
  2. #2  
    Quote Originally Posted by smileyboy View Post
    So, my 6gb microsd card
    I seem to remember reading that 4gb was the max and that using something bigger would result in erratic results (anything from not seeing excess to deleting files). I'll look and see if I can find a link...



    These threads discuss the topic...


    on the second page of his Palm Centro review, Dieter Bohn talks about >4 GB cards..

    One quick note about the microSD card - the max the Centro can read is 4 gigs - more than that and it will do anything from just see the first 2 gigs to actually erasing data off the card...
    Hope they help.
    Last edited by Malstorme; 02/20/2008 at 05:38 PM. Reason: add'l info
  3. #3  
    If this is true I'm pissed. I just ordered a 8gb micro card because someone on this forum said they had it working perfectly. The last thing I want it doing is deleting files from the card.
    Everex Freestyle - Casio E-105 - Palm Vx - Treo 90 - Treo 300 - Treo 600 - Treo 650 - Treo 700p -Centro
  4.    #4  
    I don't think it is the microsd car. I think that it is something going on with the Hotsync/3rd party software.
  5.    #5  
    Just bought a 3gb sdhc card. and I worked fine. Then I did a hotsync and the card is lost again
  6. #6  
    From my very, very limited experience, I believe it to be a 3rd party thing. When it has happened on my 700P, it has always happened after I upgraded something, but not always the same application. Twice I had to reformat the card (once the launcher file was messed up on the card and the 2nd time the launcher file was gone) and this last time (yesterday), a hard reset and it was able to see the card. I have thoughts on it being a couple of applications and have brought it to the developer's attention.

  7. #7  
    This is a common problem. has an article about it here:

    Basically there are two software apps, both written by Jeff Gibson that can possibly fix it: Cardkeeper 1.3.1 (note that the earlier version is still available and will not help with this problem), and ProfileCare. Since ProfileCare won't work on the Centro, then Cardkeeper is your best bet. The article also mentions UnCache as helping as it reduces the number of apps getting notifications, but there is an alternative now called CleanStart, which doesn't have some of the problems that UnCache did. It is still in Beta though. You can find a discussion thread and the download for CleanStart here:

    Hope this helps.

  8. #8  
    However, the situation is one that is not fixable with Cardkeeper, ProfileCare or CradleCare. I have Cardkeeper and CradleCare and the problem still happens, though for different reasons. In my situation, the card just does not disappear on its own, it disappears after an update is done - two different scenes involved. I have done a clean install in the past when first hit and it did not resolve the issue in the long run.

  9. #9  
    I think the problem is twofold, the initial round of losing the card when downloading a new app(s), and then the subsequent corruption of the disk identity. I have one card that I lost that still is not recognized, even with CardKeeper. Another card became invisible and then I was able to bring it back with CardKeeper and then used Card Reader and allowed the computer to repair the card. After that it has worked fine. My plan for the original card is to buy an SDHC card reader and then repair it that way.
  10. #10  
    Well, this won't be a popular "opinion" but I was losing my card on my Treo 755P (6 gig), and I narrowed MY problem down to ResetDoctor. I took ResetDoctor off and haven't had a problem since. CardKeeper did help me refind my card when it would get lost, but it wasn't "solid". The card would still get lost and then I would have to open CardKeeper, uncheck and recheck the boxes for the card and it would find it again.

    I think programs that monitor, in general, seem to cause issues.

    I've also seen/heard/read the theory that it is a corrupt System Preference file.

    Read as much about this issue as you can...I thought I had learned all there was to learn and was still experiencing issues 24 hours later, and then stumbled on more information that actually fixed my issue. I was just about ready to give up.

    Good luck.

Posting Permissions