Results 1 to 15 of 15
  1.    #1  
    Has anyone had a problem with their Palm suddenly refusing to recognize an SD card...or any SD card, for that matter...until a hard reset is performed? Can you share your situation and solution?

    I have a Sprint 755P, and a great variety of memory cards. I have a 2GB and a 1GB Mini-SD. I have several Micro-SDs, 1GB, 2GB, 6GB SDHC, and two micro-to-mini adapters.

    Literally out of the blue yesterday, after at least four months of steady use, my Treo stopped working with my 6GB card. Up until yesterday it had been GOLDEN. Great space, great performance.

    Now, to be fair, I had to pull some histronics to get the phone to work with the card in the first place - I had to use a Unix system to partition the card into a 3.8GB front half and whatever was left on the back half, and then I formatted the front half as FAT32/32k clusters. Had to use Unix because Windows won't allow multiple partitions on removable devices. Anyway, maybe I should've taken a clue from all that work...but...the result was that it worked like a champ.

    Then, yesterday, BackupBuddyVFS notified me that it couldn't find the card. And so did SnapperMail. And LightWav. And on and on.
    Card Info couldn't tell me what size the card was, and it also put a funny little square character in front of the volume name. <<<Hey, Palm - what's this about?!?

    I pulled the card and tested it on my Windows system. It read fine. I stuck another card into the phone and the bad behavior continued. And another card. And another. Ad naseum.

    Finally, I gave up swapping cards, and shot a full backup of my phone with, then did a hard reset.

    BINGO - the cards all worked again!

    So here it is, several hours later. I've now restored my phone, and experienced the problem as expected, twice over.

    There's got to be something on my phone that's causing this sudden inability to read the expansion card, yet oddly enough its cured by a hard reset. Anyone have any useful information to share? Thanks!!
  2. #2  
    Search for SD card issues and tou'll find more ppsts than sand on on the beach and the bigger the card the more issues. Count yourself lucky its worked til now.

    if issues continue consider a max of 4 Gb as that's the most the phone can handle. even then its comon for the phone to stop reconizing a card. usually just a soft reset does it. there are cars utility programs that claim to help. I don't have one so I can't namedrop.
  3.    #3  
    Wow...why are you so defeatist? There's several topics on here, including a recent one, which says that the 6GB and even the 8GB MicroSD cards work flawlessly.

    The failure of multiple cards to work in my 755P, while they work ini my notebook and in the wife's Centro, points toward a problem with my phone.

    Further, since everything goes back to normal with a hard reset, I really believe something's going on with the software on the phone.

    Has anyone had a similar experience, and if so, how did you resolve it?

    Thanks --
  4. #4  
    What's the card formatted as?

    I have a Sandisk 6gb micro sd and have had 0 problems formated as Fat32/16k cluster and Fat32/32k cluster.

    Both formatted in Win32.
  5. #5  
    yes I have had that exact same problem twice with my kingston 4gb. Seemed to happen after doing file transfers for the most part.

    I found cardkeeper (v1.3 I think). It has worked like a charm. I downloaded it when I didn't want to do another hard reset, installed it, ran it and voila, my 4gb card was visible again.
  6.    #6  
    I believe that I've traced the problem to Hobbyist Software's Reset Doctor.

    Jump on over to my thread at MT for more information.
  7. #7  
    I just replied to your MT post...thought it would make sense to add information here as well.

    I have been experiencing the same issue as you, exactly as you described. Last night I discovered CardKeeper and while that was fixing my problem, I still was losing the card at times. The fix meant going into cardkeeper and unchecking and rechecking the card options. However, with those options checked, I also discovered that my phone radio would not turn on after a reset. This is problematic because without knowing I had a spontaneous reset, I might not realize my phone radio isn't on and therefore I'm unreachable (I'm landline free). Not the best situation.

    So I uninstalled ResetDoctor. My card has suddenly reappeared. I do not have options turned on in CardKeeper so my phone radio turns on after a reset.

    I'll be keeping an eye on this, but right now I have to say that ResetDoctor looks like the culprit on my set up, too.

    I should add that I'm also using a 755P, and a 6 gig micro SDHC.
  8. #8  
    I’d be willing to wager that you’ll find that your card always appears after a warm reset (holding down up on your five-way).

    I had the disappearing card syndrome. I’m convinced it is a corrupt Saved Preferences file. I believe the Saved Preferences file is a single point of failure in the Palm OS. Every app puts its junk in it, and they tend to step on each other.

    I had the same kind of symptoms you're talking about, card disappears, usually when changing batteries. Sometimes it comes back on a reset, eventually it just doesn’t come back, except on a warm reset (holding down up on the five-way). Very frustrating, maddening. Then I delete an app, and I’m convinced it’s the culprit. But then the problem comes back later. I went nuts trying to figure out what was causing the problem.

    My Saved Preferences file was over 50K (as shown when you copy it to the card with FileZ). So I did a hard reset and re-built the treo from scratch. With all the apps I have, it took hours. Since then, no disappearing card. It’s been 10 days.

    Now, I’m aggressively monitoring and managing the Saved Preference file. I keep a log in a memo. Every time I need to make a preferences change that I care about, I log it in the memo. I also copy the saved preferences file to a directory on the card using Filez.

    Here’s the strange thing. About every 3-5 days, the size of the Saved Preferences file goes up by 1-2K, but with no explanation. When it does, I restore it from the smaller backup. Everything still works, and I’m keeping my Saved Preferences file to a steady size. In my case, it’s 33K.
  9. #9  
    My Saved Pref is at 51K, I can always find my card, but do get dead freezes.

  10.    #10  
    I think everyone will find this reply full of interesting information.

    First...I applied the recently-released Sprint Treo 755p ROM update, and the problem has not shown up for 48 hours. I took a full backup using BackupBuddy VFSPro, did a hard reset, ran the updater from a clean mini-SD card and restored from BackupBuddy. RD is behaving itself quite nicely. Neat, huh?

    Now before we jump to conclusions about whether the wipe-and-restore being all that was necessary, let me remind everyone that I've done a full wipe-and-restore many times while trying to isolate the problem. So I feel comfortable in saying that the ROM update is ultimately responsible for fixing things.

    Second...just before I learned that the update had been released, I discovered that I had forgotten to activate my BackupBuddy scheduled events. I use both BackupBuddyVFS Pro and BackupBuddy.NETmy BackupBuddy scheduled events were not turned on (my mistake). When I turned on the scheduled events my card dissapeared, just like it did when I installed RD. I promised you this would be an interesting reply!

    After playing around with both BackupBuddy products and RD for a little while, I feel safe saying that there is something in common between all three applications that causes the SD card to become unreadable whenever an automatic operation is scheduled. How peculiar is that?

    Anyway, all of this seems to be a moot point for me now, because it appears that the ROM update has cured my ills. But what of the people on other networks who may not see the ROM update soon, if ever?
  11.    #11  
    Quote Originally Posted by RJKinsman View Post
    I’m convinced it is a corrupt Saved Preferences file.....I had the same kind of symptoms you're talking about, card disappears, usually when changing batteries. Sometimes it comes back on a reset, eventually it just doesn’t come back, except on a warm reset (holding down up on the five-way). Very frustrating, maddening.
    Thank you very much for contributing to this topic.

    My symptoms were a little different than yours. When my card was not being recognized, Card Info could see still see it, but there was a square as the first character in the card name, and the size was reported as “None.”

    I also do not believe that my prefs file was to blame, because it was not a factor in the majority of my testing. Here’s the scenario, distilled to its essence:
    • Hard reset
    • Card Info reports OK
    • Install Reset Doctor
    • Run Reset Doctor, accept defaults
    • Card Info reports OK
    • Soft reset
    • Card Info cannot recognize the card
    • Uninstall Reset Doctor
    • Soft reset
    • Card Info reports OK
  12. #12  
    Quote Originally Posted by xpanmanx View Post

    When my card was not being recognized, Card Info could see still see it, but there was a square as the first character in the card name, and the size was reported as “None.”
    I had this symptom, too.

    The reason I'm not sure that uninstalling Reset Doctor is the problem is two-fold:
    1) I don't have Reset Doctor, yet my symptoms seem very similar to yours.
    2) Uninstalling applications always seems to resolve it for a while. You can find other threads about this problem where people find that uninstalling one application or another resolved the problem, so they conclude that the last one they uninstalled was responsible for losing the card.

    At first, I thought it was Sprint Mobile Email. When I uninstalled it, the card came back; but then the problem came back after a few days. Then I thought it was Butler. When I uninstalled Butler, the card came back; but again, that only temporarily resolved it. Besides, I've gotten quite used to Butler's features, and I didn't want to give it up. Then I thought it had something to do with Intellisync. It seemed that if I let Intellisync go through one sync, and then reset, the card came back; but after a couple of weeks that stopped working.

    Can you see how maddening it is?

    Anyway, the common element in all of these resolutions is that you're affecting the Saved Preferences file in some way. At least, that is my current theory.

    I'm up to 18 days now since rebuilding my Saved Preferences file, and I haven't lost the card once. If I suddenly lose use of the card, I'll restore from the most recent Saved Preferences backup, and see if that resolves it.

    By the way, in Filez, it shows a different size for a file when it is in internal, then when you copy it to the card it shows a different size. I don't know why. I'm monitoring the size of my saved preferences file as shown on the card, not in internal.

    One other little thing (and this may blow my whole theory about saved preferences): On the day I did the rebuild, I first rebuilt it, and the card problem went away. Then after that, I applied the Sprint updater, and it has stayed away since. So really, I don't know for sure which one resolved the problem. Actually, it could be a combination of both. There could have been some bug causing a corruption in the Saved Preference file, and the update fixed it.

    Anyway, if it does recur, I plan to restore the pristine saved preferences file that I have backed up on my card and see if that resolves it. If it does not recur again after a couple of months, then I'll get tired of saving versions of the Saved Preferences file, and come to the conclusion that it was actually the updater that resolved the problem, not the re-built saved preferences file.
    Last edited by RJKinsman; 02/23/2008 at 02:07 PM.
  13. #13  

    Thanks for your post. This has been a perplexing problem for sometime. I have felt bad for Rob at HobbyistSoftware because I think his products have received much of the blame for this problem. He has been trying hard to figure it out. Noone has been able to figure it out, and thus far there have been only partial solutions (Card Keeper, CradleCare), that are more directed at fixing the symptom then the problem. I have a card that no longer can be read, no matter what I've done. I've used Card Keeper, installed the new ROM update, cause someone said that caused his to reappear, hard reset, etc. and nothing has worked. I am wondering whether in addition to the cause of the problem, if there is a secondary problem of corruption of the card that occurs. I did notice a couple times that I would get an error message sometimes on my card that the Startup application was unreadable. I fixed this by using CardReader and allowing my desktop to repair it. I've been meaning to purchase a real SDHC card reader so I can see if this original card is toast or whether it just needs to be repaired and reformatted. Anyway, thanks again for the post.
  14. #14  
    Wow, this is much more serious than I thought. If Rob from Hobbyist is struggling with it, it’s way over my head.

    I think there is something to your idea about secondary corruption on the card. With my experience, I was always able to read the card with a soft reset, so that eliminated a hardware problem. Actually, a hardware problem would have been much simpler. I would have just gone over to my friendly sprint repair center and went away happily with a new unit.
  15. #15  
    I have had very good results since re-building my Treo, starting with a hard reset. Note, a complete re-build, not a restore. I re-installed every app from scratch, entered all of the registration keys, all the preferences, etc. It took a whole day.

    After re-building, the card was recognized. At that point, I copied “Saved Preferences” into a directory on the card using Filez, and re-naming it with the date. I started a “Saved Preferences Log” using Keynotes. Every time I made a change to preferences, I made a note of it in the log, and saved the new version of “Saved Preferences” to the card and re-named it with the date. I had no problem for exactly one month (2/6 to 3/5). On 3/5 I lost the card. I restored from the most recent backup of “Saved Preferences.” That resolved it. Now it has been 10 days since I lost the card. We’ll see how long that lasts.

Posting Permissions