Results 1 to 18 of 18
  1. ssrjazz's Avatar
    786 Posts
    Global Posts
    790 Global Posts
    Anyone else having issues with the On Demand app that comes with the 755p?

    I'm getting some sort of error messages about missing nai and something else.
  2. #2  
    No issues for me.
  3. #3  
    i got this somwhere... should be able to fix this on the fly...
    Attached Files Attached Files
  4. #4  
    What is this on_demand_upgrade?
  5. #5  
    I haven't tried it, but found this:

    Check out the second-to-last post.

    EDIT: Another thing you could try (after doing a full backup with NVBackup) is to delete On Demand, then use FileZ to move (not copy) your unsavedpreferences file to your SD card and do a soft reset. This will "trick" your device into thinking you did a hard reset and it will reinstall any pre-installed applications your previously deleted. Move unsavedpreferences back to your device and soft reset again, otherwise you'll have to re-enter your 3rd party registrations again.
    Last edited by jigwashere; 12/28/2007 at 08:21 AM.
  6. ssrjazz's Avatar
    786 Posts
    Global Posts
    790 Global Posts
    I think Handmark changed something on their end.

    The error message I'm getting is:

    "This account creation call is missin the following parameters - mdn (mdn),nai (nai). Please try again or visit for more info."
  7. #7  
    On Demand is working fine for me. I think it's your device and recommend re-installing On Demand as I described previously.
  8. ssrjazz's Avatar
    786 Posts
    Global Posts
    790 Global Posts
    I've 'reinstalled' it several times ....still gives the error.
  9. #9  
    At this point, you should contact Sprint for support.
  10. #10  
    I just thought of something else -- do you have DA Launcher installed? I've tried using DA Launcher on my 755p, but it somehow prevents On Demand from working. Delete DA Launcher and see if that works. I'm using McPhling instead and am very happy with it!
  11. #11  
    I was on the phone with Sprint support for an hour and a half today. They tried everything, resetting my phone and all. I live in St. Louis and he said no problems reported in St. Louis. I get MDN and NAI error message for OnDemand and none of the links on Sprint Vision homepage work, they just refresh the screen. I did notice you can go to direct URL's like, etc. Also my Media (Sprint TV) gives an error message as well. So basically anything tied to Sprint services are not working, just the bare bones access to the network seems to be fine (meaning you can go to direct URL's). I then went to Sprint store locally and they said another person has same problem, so probably a server error. I hope Sprint fixes this since I have been having this error for about 3 days now.
  12. #12  
    On Demand is working for me in Michigan.

    It does sound like a local server issue. (If others in the locale are having the same issue. )

    However, if a Sprint store Treo unit can contact On Demand -- then it is an issue with your device -- either hardware or software.

    Were any of the resets tried a hard reset?

    If a store unit can contact On Demand -- then it is time to try a clean install -- this will determine if you have a hardware issue or if a software conflict or corruption is the issue:
    Last edited by gtwo; 12/29/2007 at 09:44 PM.
  13. #13  
    On Demand works for me. I mainly use it for stock quotes.
    Sprint 755p, 700p, 650 - I am not a geek! Really!
  14. #14  
    On Demand and Sprint TV are not working my Centro and my wife's 755p. Anyone else in the midwest having issues?

    Is it worth calling Sprint?
  15. #15  
    This seems to be broader than just on demand and sprint tv. All of the links to sprint services are dead on the vision homepage in blazer.

    Sprint is investigating in the Minneapolis market.
  16. #16  
    I'm in Minneapolis and have no problems with On Demand or accessing my account in Blazer from the Sprint Home page. I haven't noticed any problems all weekend.
  17. #17  
    I'm also in St. Louis and am having the exact same problem with On Demand. I agree with Perry that it's probably a local server issue. I'll wait it out for a few more days before I waste my time sitting on the phone with Sally at Sprint in South Asia.
    The only thing that separates the men from the the lessons they learn.
  18. #18  
    Both On Demand and Sprint TV are working again in Minneapolis.

    Thanks Sprint!

Posting Permissions