Results 1 to 7 of 7
  1.    #1  
    Why is it I can charge via the USB cable when it is plugged into my home PC, the one I hotsync to, but not on any other PC's?

    I suspect there must be some driver on my Home PC that is allowing for this to happen, as I notice that the charging only starts after windows is fully booted.

    It would really be handy to charge this way at the Office, but I cannot install software on the Office PC.

    Is their a mod/hack for the treo so it will charge via any available USB port?
  2. #2  
    Actually your best bet is to get the USB charging cable from Palm. Only suggesting them cause I own one for my TX, and one for my treo, so i can keep both charged at work.

    That is your best bet for USB charging, otherwise you will get the trickle charge, which can take forever.
    Zire 31-> Zire 72s-> T|X

    Nokia 5160-> Nokia 3100-> Nokia 3220-> Treo 650 Unlocked(modded ROM)-> Treo 680 Unlocked(modded ROM #8 within 15 minutes of receiving the box)-> Treo Pro(hacked as well)
  3. #3  
    You are correct that it needs a driver installed. I don't know how you can do that without admin privileges on your local machine. You might be able to look in your Windows/ini folder and see if there is a palm file there. Or, when it is connected to your home computer, you might be able to go to device manager when the Treo is connected and see what files it is using. If you could figure that out, you might be able to copy them to your work computer.
  4. trwrt's Avatar
    110 Posts
    Global Posts
    612 Global Posts
    I don't think it has anything to do with drivers, because I just plugged mine into a PC on which I have never installed any Palm software and it claimed to be charging (and this was with a non-Palm sync-n-charge cable also). It must be something else. Do the USB ports on your office PC work with other devices?
  5. #5  
    I agree with trwrt. Nothing to do with drivers. With the standard usb cable it will trickle charge, but it would take around 8-12 hrs to get a full charge. Maybe the usb port on your computer that you are using is not able to provide sufficient power.
  6. #6  
    I did this test on my 700P. Maybe it does not work the same as the 680.

    I found the driver listed in the Windows Device Manager. It is PalmUSBD.sys in the Windows\System32\Drivers folder. I renamed this file and plugged in my Treo. It gave me the USB error beeps and would not turn on the charging light on my Treo. I renamed it back to the original name, and it connected and charged.

    I then plugged my OEM cable into a USB AC adapter, plugged in to an outlet. It would not charge.

    I'm not talking about trickle charging. I am talking about when the charge light comes on. So, you should be able to copy this file to your work computer, even without admin rights, unless they really have it locked down. You other option, is to just get another AC charger for your office.
  7. #7  
    Every motherboard is different. Maybe one conforms to the USB standard and the other doesn't. It can even vary from port to port on the same motherboard.

    I spent hours and hours over a week debugging a scanner. It would scan, start transmitting, lock up and reboot. Again and again. But only on big pictures, small ones were fine, or low resolution. Reading a completely unrelated article, I learned that some devices power their communication with the USB power, and if the motherboard isn't up to spec the voltage will drop and the devices will act bizarrely. Wiring up the computer's front USB ports and plugging the scanner into those solved the problem. Another solution would have been to use a powered USB hub.

    PS: half the time I turned off my computer the USB would stop charging my phone. It wouldn't charge at all unless the computer was on when I connected the phone. But once I plugged the USB cable into the powered USB hub on my monitor all my problems were solved.

Posting Permissions