Results 1 to 3 of 3
  1.    #1  
    I just bought a used treo 650 off Ebay and it arrived today. Everything worked fine except a few keys that were somewhat "depressed". I decided to take it apart to see if there was dirt or something that could easily be fixed. Everything went as smooth as I could imagine however, now that it is all back together the screen will not light up. I have connected and reconnected the ribbons numerous times thinking I missed a connection. Nothing. The power gets to the screen from the ribbon, correct? I am at a loss. I am going to sleep on this. Any suggestions? Thank you
  2.    #2  
    Well, after three hours of mastering the art of assemby disassembly of the 650, I figured out my problem. I thought I would share in case anyone else has a similar problem. My assumption that the power to the screen was coming from the ribbon connected to the motherboard made the most sense so I focused on that connection. Sure enough, I was not pushing the ribbon from the screen far enough in to the connector on the motherboard. The ribbon from the screen has a two white lines imprinted on it which I figured was a indication of how far to put the ribbon in. After working it a little bit, the ribbon went further into the slot on the mother board. After securing with the clip I found the edge of the clip was right on the second white line on the ribbon. (They obviously were put on the ribbon for a reason) Problem solved. I hope this makes sense.
  3. #3  
    Course it does, jonp0515. Good work!
    Alexandre Freire
    Treo 650 Unlocked GSM

Posting Permissions