Results 1 to 3 of 3
  1.    #1  
    On my 650 when I type "j" I get an "h", and when I type "y" I get a "u".

    I have tried a soft reset and a hard reset and I still get the same problem. Sometimes a soft reset will fix the problem for awhile, but the problem comes back.

    I don't if it"s a hardware or software problem. Any one seen this problem and know how to fix it?
  2. #2  
    Hi letnes.

    It seems that your problem is hardware, on the keypad board, to be more specific. At least, that would explain the erratic behaviour. You could open your Treo and try to do some cleaning, but I'm reluctant in giving you this advice, because I do not have the necessary technical knowledge to tell you if that would be of any help. All I can tell you is that if it was me, I would do it.

    If turns out your problem IS the keypad, then it's easy to replace it.

    Let us know about the outcome.
    Alexandre Freire
    Treo 650 Unlocked GSM
  3.    #3  
    I had that feeling too, but I was hoping to be wrong. I will open it up and see if I can fix it.


Posting Permissions