Results 1 to 4 of 4
  1.    #1  
    Hi guys, maybe someone can help me. It's a couple of week that my Treo 650 does not charge the battery anymore.
    I've tried by replacing the battery and using the old battery in another Treo (charged perfectly), I've also tried by changing the charger or using a usb cable charger... no way same story.
    Tha strange is that it does not charge the battery at all sometimes, other sometimes it charge just few percentage (1% or 2%) and sometimes (really strange) it fully discharge the inserted batteries.

    Any idea? Could be the main board?

    Thanks in advance
    Last edited by Carlo; 09/11/2007 at 11:30 AM.
  2. AMVMommy's Avatar
    68 Posts
    Global Posts
    91 Global Posts
    This is happening to me as well. Takes hours and hours to charge or will be completly discharged in the charger by morning. Always double-checking the connection and does this with multiple batteries and chargers. My 650 is a couple of years old. Waiting on Verizon to get their act together for a 755P.
  3. magic25's Avatar
    63 Posts
    Global Posts
    67 Global Posts
    My 2-year old Treo 650 no longer charges batteries too. My solution was this, I bought a Palm Treo Battery Charger (part number A2182) to charge the battery outside the Treo, charges like normal. I have 2 batteries so I alternate between batteries.
  4. #4  
    I had the exact same problem. The phone is bad. If you have insurance and go to a Sprint corporate store, they will give you a 700P and force you to upgrade to Power Vision. I didn't want that and went to different affiliate stores till I found one that still have refurbed 650's. The fella in the affiliate store tells me they get the refurbs from a different source than Assurion and Sprint corporate. Your alternative is to buy the OEM cradle or after market charger that can charge the battery by itself.

Posting Permissions