Page 3 of 3 FirstFirst 123
Results 41 to 45 of 45
  1. #41  
    Hey bmwmc,

    I'm having the *exact* same problem. I didn't get an error message like you, but I definitely haven't been able to hotsync since getting rid of 4.0.1 (which I finally gave up on due to the AvantGo problem). I called Handspring technical support and they told me that I need to remove "palmusbd.sys" (which, of course, I can't find). They said I needed to call Palm's tech support line for help with this, but I'm saving that as a last resort. I have a feeling that Palm won't be too interested in helping someone who doesn't own one of their handhelds and went against the explicit warning on their web site about trying this software with anything other than a palm device. I'll try ProjectZero's suggestions when I get home tonight and keep my fingers crossed.

    By the way, I'm still using 4.0.1 here at work (a serial connection) with no problems whatsoever--thank goodness! I don't know what I'd do if I couldn't hotsync either place.
  2. #42  
    Fire up RegEdit or your favorite registry editor (I happen to like RegHance, which you can download at

    If the Palm Desktop is installed (Palm or Handspring), uninstall it and reboot.

    Make a backup of your registry and then perform a search on "palmusbd" with the registry editor and make sure you are not searching based on case sensitivity. You should come up with at least two hits-- but it may take a few minutes for the search, especially if your Win32 system contains a lot of installed components (hardware and software).

    In the RegEdit that comes with Windows, you'll have to make use of the "Find Again"/F3 function to continue to search (other registry editors may function like Windows Explorer-- continues to search and return you all of the results; hence the mentioning of using RegHance).

    You should find one or all of the keys in the "HKEY_LOCAL_MACHINE" hive.

    One of them should be in the HKLM\Software\Microsoft\CurrentVersion\Setup branch.

    The other(s) should be in the HKLM\System\CurrentControlSet\Services\PalmUSBD

    and HKLM\System\CurrentControlSet\Services\Class\Palm.

    Don't be surprised if you see multiple entries for "PalmUSBD" in the CurrentControlSet branch.

    Once you've located them all, for each entry, delete the entire entry.

    You should also check for a file called PalmUSBD.inf (yes, INF) in your \Windows\INF directory-- if it's there, delete it.

    You're not done yet.

    Repeat the registry search for "visorusb" and do the same thing-- if you find an entry for it, delete it.

    Also, see if visorusb.inf and visorusb.dll is located in your \Windows\INF and \Windows\System32 directories-- if they're there, delete it.

    Now, you can reboot and run the Handspring-version of the Palm Desktop 3.1 again.
    Last edited by ProjectZero; 05/23/2001 at 05:51 PM.
  3. #43  

    Just wanted to say THANK YOU so much for the fix. I tried Easy Way #1 last night and it worked like a charm. I know it must have taken a long time to type all that out, so wanted to make sure you knew how much your help is appreciated. Yeah--I can sync again!!

    Now if we could just get Handspring to come out with a truly compatible version of Desktop 4.0.1.....
  4. #44  
    ProjectZero has helped me before too. good guy.

    I tried to download the 'reghance' he suggested for future registry problems. That site seems to be down.

    In case anyone else wants to get 'reghance', I found it at:
    "I cannot live without books." Thomas Jefferson
  5. #45  

    Thanks for taking the time to help. I am again happily using DeskTop 3.1. Pilot Install, which did not work under 4.0.1, is happy again as well. BTW, Pilot Install is a great little program for installing apps without performing a full hot sync. Saves a lot of time when you just want to install something. Thanks again!
Page 3 of 3 FirstFirst 123

Posting Permissions