Results 1 to 6 of 6
  1.    #1  
    It seems i can't get past the "rainbow" getting the waiting for phone message how do i move on?Please help.
  2. #2  
    What opperating system are you using it will not work with vista
  3. #3  
    First time I used the rom tool it said phone had a password and wouldn't connect. Backing up data and doing a hard reset corrected the problem.
  4. TRgEOff's Avatar
    589 Posts
    Global Posts
    591 Global Posts
    Quote Originally Posted by bbayah View Post
    It seems i can't get past the "rainbow" getting the waiting for phone message how do i move on?Please help.
    I posted my solution to my instance of this the other day in "Custom ROM the easy way" thread:

    Originally Posted by Casalexa
    I am in the "Rainbow Bootloader". The red band reads "Boot load v 0.24"
    The green band reads "SD" and the blue band reads "usb".
    The ROM Tool has "found phone, waiting for bootloader", I get two green progress bars then.............nothing.
    Then I quit the ROM Tool and relaunched with my phone still in "Rainbow Bootloader" mode. The device status reads: Error: Unable to open \\WCEUSBSH001. Is this the result of not starting the process over in the proper order or is it a clue to some other problem?

    Originally Posted by TRgEOff
    I'm now getting this problem too. I have done many ROM upgrades in the past without any hassle at all, the last one probably four months or so back. Occasionally I also get a "Waiting for phone.." error as well.

    My hope was that it may have been due to some a poor USB connection, but I've now tried 3 different cables, and all the USB ports on two different PCs. I suppose it could still be a hardware problem (e.g. the Athena socket on the Treo might be damaged somehow).

    Anyone have any ideas?

    Ok this is now solved. It seems to have been a matter of two problems:

    1. Poor physical connection: When I used two very strong elastic bands to hold the adaptor in the Treo, this led to the ROMTool seeing the phone.

    2. Restoring my (most recent) version of .NET back to 2.0 (and then rebooting PC)

    Interestingly there was still an 404 error noted in the ROMTool log as the connection was being made, but if I waited long enough (45-60s) then the process of connection went to completion OK.

    Also of some note: I notice now that after Uploading a new ROM my Treo now always goes into a reset loop, but this is easily fixed by a hard reset, and then the revised ROM is ready to use.

    One last (note to myself) having to do so many connections led me to fine-tune my procedure for bringing up the Rainbow screen, which had always been a bit hit-and-miss.

    100% system:

    1. Hold down hotsync button FIRST.
    2. While still holding hotsync button down, depress Reset button on Treo with stylus and then release it.
    3. Finallly: release hotsync button.

    good luck, worth persisting!

    Treo 650 1.20 LAP.
  5.    #5  
    All has gone well,but am stuck at the bootloading.The program is still waiting for the bootloader,it one hour now.
    Another thing is i cannot get the token button to go on.
  6. MashBill's Avatar
    11 Posts
    Global Posts
    13 Global Posts
    Same here. I am no longer able to run the RomTool. Can't seem to get past the bootloader. I have never had a problem previously.


Posting Permissions