Results 1 to 7 of 7
  1.    #1  
    i just replaced the battery of my treo 600, it solved the hard reset issue i had before. worked out fine for a couple of months, but now it has a red 'X' mark on the battery icon and it did a hard reset a couple of times. what does this red 'x' mark mean?
  2. #2  
    Battery is not charging.
  3.    #3  
    battery not charging? but its always there even if the unit is not plugged
    any other possibilities?
  4. #4  
    Some possible reason is that the battery level setting are not matching what the threshold should be. The Treo 600 battery are not designed to be user replaced. When you replaced the battery, did you need to solder the battery or just cable connection?

    Can you see if you could take a snapshot or printscreen (via Screenshot or Screendump) of your screen and post it just to see? Based on what you said, the battery seems to be charging and working after disconnecting the phone from the charger.

    Also for the Treo 600 use only, try this link: Treo Battery 3.0 <-- mobile user link
    Last edited by ronbo2000; 06/24/2007 at 06:10 PM.
  5.    #5  
    just cable connection, i did not have to solder it.
    yes, it charges and works after disconecting from the charger except for two or tyms it did a hard reset since i replaced the battery.
    il try to get a screenshot of it.

    another problem is that people i call with my fone sometimes hear a buzzing sound on the line.

    hey thanks for your help.
  6. ktm97's Avatar
    341 Posts
    Global Posts
    392 Global Posts
    I had a 3rd party battery only last a few months, some are better than others, as for the buzzing you need to wrap tinfoil around the wire between the battery and it's connector.
  7. #7  
    What ktm97 said - for the buzzing sound.

    Lucky you on the battery connector. I bought a battery replacement for my phone but when I opened it up, it requires soldering. Since those are very small connectors, I am sure to damage those connectors. I gave up.

    Any chance you did those screenshots?

Posting Permissions