Results 1 to 7 of 7
  1. jOzh's Avatar
    3 Posts
    I'm having this annoying problem which I can't seem to resolve. It looks like my Treo 650 is not capable of maintaining a bluetooth connection with my GPS receiver.

    The GPS receiver I'm currently using is the Adapt AD-750, but I had the exact same problem with the Adapt AD-300. This led me to believe the problem lies with the Treo and not with the GPS unit. Ok, so let me explain the problem in more detail:

    Pairing the Treo with the GPS receiver goes smoothly, no problem whatsoever. When I launch TomTom Navigator 6, I get the message that a connection with GPS is being established, followed by a message that no usable GPS signal is received for the last ... seconds. This is all normal since I'm indoors when making the connection. However, after about 20 seconds, the blue light on the GPS receiver starts to blink quickly and TomTom says that no GPS device is found. A few seconds later, I get the choice to pick the GPS device I want to use, including my Adapt AD-750, which I naturally pick. Again, the connection lasts for about 20 seconds and the whole story repeats itself.

    I tried a soft and a hard reset, both didn't resolve the problem. I tried two different GPS receivers, no help there. I've got firmware 1.20 on my Treo.

    Whats really strange is that about a year ago, I owned an Adapt AD-300 GPS receiver which worked perfectly! Unfortunately, I lost it and I re-bought the exact same model about a year later. When I got the above-mentioned problem, I first thought the GPS receiver was broken so I traded it for the Adapt AD-750, which didn't solve the problem...

    Is someboy familiar with this problem and/or knows how to get the two devices to stay connected? I'm seriously considering upgrading my 650 for a 680 because of this... Any help is greatly appreciated!
  2. #2  
    Is the GPS device properly paired using the bluetooth utility? Did you need to (you should) enter in a passkey?

    I thought this was only a problem with the early MTK chipsets. This is the first time I've heard of this happening with a SirfIII chipset. I think the MTK chipsets were having problems because the units had an auto-off function which the Palm OS did not work well with. Unfortunately, I've heard the same type of problem was happening with the 680, possibly the 700 as well. It has to do with the implementation of bluetooth on the Palm OS.

    I had very similar issues, though not as bad, with the Treo 650 and the iBlue 737 (aka QStarz 810). Though tolerable, I upgraded to a different version GPS.
  3. jOzh's Avatar
    3 Posts
    Thanks for your reply.

    Yes, I paired the two correctly. I did enter a passkey (0000) and there is a secure connection.

    I think the problem lies with the Treo and/or the navigation software and not the GPS module. On occasion the two do stay connected, but only after I change something in the bluetooth options of the Treo. It doesn't matter what I change (for example, I set discoverable to no or yes, or I enable device name cache or I disable it). When I start TomTom after this, the connection sometimes keeps perfectly in place. If I, while navigating, go to my sms messages and after that back to TomTom, the problems I mentioned in my first post reappear.

    Very weird and I really expect it to be some sort of software problem.
  4. jberger's Avatar
    241 Posts
    Global Posts
    244 Global Posts
    Delete your BT prefs and trusted devices files. Then reset the treo (cold boot) and re-pair. Usually fixes random BT disconnects.
  5. jOzh's Avatar
    3 Posts
    Quote Originally Posted by jberger View Post
    Delete your BT prefs and trusted devices files. Then reset the treo (cold boot) and re-pair. Usually fixes random BT disconnects.
    Thanks for your reply. I can't seem to find where I can delete my BT prefs. Which file do I have to delete for this? TIA!

    [edit]Ok, using filez I tried to delete the following files:
    Bluetooth Device Cache
    Bluetooth Trusted Devices
    Bluetooth Prefs Backup
    The last file won't be deleted, I get a message saying "Database Protected in Item"
    Last edited by jOzh; 06/06/2007 at 09:17 AM.
  6. timmo's Avatar
    98 Posts
    Global Posts
    167 Global Posts
    Any luck doing this? I am having a similar issue with my Treo 680. I can no longer get my BT headset to work with my 680, and want to reset my Bluetooth trusted devices database. thanks.
  7. #7  
    I never got my 650 to stay working with the BT headset, and when i got my laptop with BT, it wouldn't stay connected long enough to do a sync.

    Which led me to deduce that i have a BT problem on the phone.

    HOpe the prefs can fix it, I wonder where i put my headset - maybe it will work on my new phone?!
    m100(for 1 day)->Sony PEG-S300->PEG-N710C->PEG-NR70 (needs a new battery!)->Treo 650 (bad connector)->650 (dead ear speaker)->700p (sucky battery life)->new 700 on way

Posting Permissions