Results 1 to 6 of 6
  1.    #1  
    i have a 650 and for the past few days ive noticed that when i plug the phone into the charger, it no longer charges. the red charge light keeps flicking on and off. i'm not sure what the issue is if i'm still able to hotsync without any issues. I tried to hotsync and it works, and even tried a different charger, and have the same problem

    pls help!!
    Blessed beyond measure!
  2. #2  
    do you plug the charger directly into the phone or go through the hotsync cable?
    I had to have a 650 replaced because of a bad hotsync connection.
  3.    #3  
    i plug the charger directly into the phone... no hot sync cable
    Blessed beyond measure!
  4. #4  
    maybe try it through the cable?
    seems like the charging port contacts may have gone bad.
  5. AMVMommy's Avatar
    68 Posts
    Global Posts
    91 Global Posts
    I think this is the same problem with my 650. Is there anything I can do about the port contacts? I can plug it into a wall charger, a desk charger and via the sync/charger and occasionally it will charge, but mostly it won't. And sometimes it will just run out the battery. Help!!!
  6. #6  
    Did anyone find a solution to this problem? Mine does the same thing!

Posting Permissions