Results 1 to 7 of 7
  1.    #1  
    Can anyone help me out...I have a Treo 600 and the touchscreen no longer responds. I tried recalibrating the touchscreen and that didn't work. I also tried a "hard" reset and that didn't work either. Is there anything that can be done or am I screwed?
  2. #2  
    Was the any other problem prior to this one? Do you know what happened immediately before this problem occurred?

    If you did hard reset it, the screen should respond back. Did you lose all your data?
  3.    #3  
    actually I contacted the Ebay wireless store I purchase the Treo from and they suggested that I charge the battery to full and then do the reset. That worked. Thanks for the reply. Have you heard of OZMAIL or 3020? I keep getting text messages from the address 3020 with a message of letters and numbers that make no sense. I replied back to the address to stop sending messages but get an error message saying that the reply address is invalid. Any ideas? Thanks.
  4. #4  
    Second hit when I googled OZMAIL was this -> which describes the cause and the fix.
  5. #5  
    Interesting fix for a non-reactive screen, it is good to know these things. Glad it worked out with you.
  6. #6  
    Thanx for the info it good to know for future knowledge I also had some problem with my Treo but luckily I found a great tech support site that helped me deal with it. They also have free live chat support.

    Here is the page for Treo 600 Support

    I hope it will help

  7. cadams's Avatar
    301 Posts
    Global Posts
    320 Global Posts
    Another fix is to make sure no lint or dirt is jammed in the side of the screen. I had a problem calibrating a 600 but after taking a thin index card and getting lose debris out of the edges of the screen it worked fine.

Posting Permissions