Results 1 to 10 of 10
  1.    #1  
    I have an unlocked GSM 650 and service with Cingular; firmware 1.71, software 1.20-ENA, hardware rev A.

    I returned yesterday morning from a two-week trip to Thailand. My phone was working fine before I left, and it was working fine in Thailand on one of their local providers (both calling and texting). On return, my phone cannot now register with Cingular - it searches for the network for several minutes and then says "No service - SOS only".

    I have tried soft resets, removing the battery, switching the radio on and off, all to no avail. I have trawled this forum and others but can't see a solution.

    I have tried the SIM card in my girlfriend's phone and it works; I have tried her SIM card in my phone and it has the same problem. So, the issue seems to be with the phone.

    Cingular are no help.

    I am sceptical that my phone developed a problem on the flight from Bangkok to New York - it seems to be some issue registering with the network. [Maybe locking into the roaming network has caused the problem? But I travel internationally a lot and have never had this issue.]

    Does anyone have any idea what this could be or what I can do to resolve it? I don't really want to spring for a replacement phone right now, especially as I don't think this one is really broken!


  2. #2  
    May be the SIM tray. Do you have the "new style" one? The old one did not hold the SIM card tight enough and you could lose you phone connection. Here is a link to what they look like.

    Some people have put a sort of "shim" between the SIM and tray for a better connection. I don't believe this has been necessary with the new one.
    SE P900-->Treo 650 (Cingular)-->Qtek 9100-->Treo 650 (Unlocked)-->Treo 680 (Unlocked)-->Treo 650-->ATT Tilt-->Blackberry Curve-->?PRE
  3.    #3  
    I do have the new-style SIM tray; I've tried putting some paper in behind it anyway to tighten the connection and still having the same issue. Thanks, though.
  4. #4  
    Well, it was worth a shot. Have you tried a hard reset? I would try if you've expended all other options. Just make sure you back-up everything. I have a free program called Nvbackup that works like a charm for back-ups and restores. It brings me right back to my normal state after a hard reset. Google it and you should find it. I like this better than the Hotsync way. Just a thought...
    SE P900-->Treo 650 (Cingular)-->Qtek 9100-->Treo 650 (Unlocked)-->Treo 680 (Unlocked)-->Treo 650-->ATT Tilt-->Blackberry Curve-->?PRE
  5. #5  
    Have you tried resetting your Call Preferences with the network since you've been back? That reconnects the SIM to the tower in your area and sets up your account settings. It's in the Phone App menu.

    You could also try calling Cingular and having them re-register the network OTA.
  6.    #6  
    It gets more complicated... so I did a hard reset, and found that I could then connect to Cingular; but when I restored (I use backupman) I now have the same issue. So there must be a corrupt setting somewhere. I guess I will have to do a hotsync restore after the hard reset to isolate the bad file.
  7. #7  
    Look for files associated with the Phone application or GSM* ID maybe.. Strange stuff.
  8. #8  
    I've seen this before when people go oversees and use another sim card.

    Try this - search for the Network Select hack if you don't have it already, and download that to your phone.

    Run it, and then on Search Bands, select Auto. Then, click Automatic Mode on the lower right.
    at&t Treo 680, SW 2.11-ATT
    Cingular Treo 650 Unlocked, SW 1.17-CNG/FW 1.51
  9. #9  

    If it's not for your specific phone and firmware, your Treo will reboot endlessly. You can easily get out of it with a warm reset, then deleting the overlay file you installed, but be warned.
  10.    #10  
    Brilliant! That hack did the trick.

    I restored my original config (the one wasn't registering w/the network) and installed the hack. I did a 'Select network' and found it was searching on 800/1800 bands rather than 'Auto' - I changed it to 'Auto' and it found Cingular again.

    While overseas I did have access to the 'Select network' function (only blocked in the US for me - and I was using the same SIM) and I do remember at one point having it search specific bands to find a working network. [I guess you could say user error was the root cause... but Cingular partially blocking the 'Select network' capability doesn't help.]

    Thanks for your help and suggestions. Next time I'll be more careful while overseas.

Posting Permissions