Results 1 to 5 of 5
  1.    #1  
    Hi there, I have my treo for a week now, and the only different thing that I did yesterday, was to shoot a small 15 seconds video.

    I came back home and plug the device on the wall charger.

    This morning, after plug it off the charger, the light was green, but no lighting, just green all the time, I tried a soft reset using Treo Launcher, and the phone never woke up.

    I took the batery off a couple of times and finally there was a pop that says, "Batery almost empty" turning off the device... WTF??

    I plugged it in again into the wall charger, and wait for 5 mins.
    Same pop up.

    I took the charger to work, and now Im in the office checking that "Yes I should install the camera update" even when I bought the phone on March 16th almost 2 months later than they says the bug was fixed...And all the devices are ok now... well nop, mine is not, I have to update that if I can finally put it to work. has been charging for 30 mins but the phone is still not turning on.
    I will wait one hour untill the batery get some charge.
    Is there any other thing that I can do?

    Thanx for sharing.

    Info Added: The Phone turned on after 1 hour of wall charging.
    Everything is fine, the only advice that I can tell is, no matter when did you purchase your phone, check for the camera update entering yous Serial number here:
    Last edited by Lardo; 03/28/2007 at 10:23 AM. Reason: Adding info
  2.    #2  
    After 4 hours of charging...
    I disconnected the Treo from the wall charger and same thing....
    Green light, Battery icon like still charging, soft reset and no wake up.

  3. #3  
    I'm so sorry to hear about this
  4. #4  
    Can you return the battery to the store you bought the treo at? Will they let you try a new battery?
  5. OnTheFly's Avatar
    99 Posts
    Global Posts
    104 Global Posts
    This doesn't sound like the battery/camera issue. It sounds to me like somethings not right with your treo. I'd bring it back to the store if I were you and get anew one. This is not normal.

Posting Permissions