Results 1 to 12 of 12
  1.    #1  
    Hey all,
    I see many of you have been down this road before... and I'm thankful for all the great info and programs that are available from the users to try and fix broken phones. I recently upgraded to a 700p and wouldn't you know it, the minute I hot synced my old phone with the PC to backup the data, it died on me. Well, not really died, but seems to be rather useless. I am pretty confident the failure was related to the hot sync cable... it usually takes a bit of mashing around to get the computer to recognize the device when I hook it up. But usually once the little USB connect sound chimes, I'm good to sync and run. I was able to backup all my data... so that's good. I left the old phone connected while I played around with the new one (not connected). I went to swap the phones out and the old Treo was displaying that CBOD (color band of death) and the text Bootload v 0.19 ARGH! I pushed it aside, installed my new phone, pulled the data I wanted and synced... all was good.... but the old phone lay to the side, looking sad and dejected. I spent a good 6 hours with it last night trying to get it up and running. I read TONS of info on these forums and ended up trying to build my own fresh ROM from the latest Sprint Firmware update. I was able to complete all the steps and got all the feedback that seemed correct... but when all was said and done, the phone returns to the CBOD screen. I have all the steps listed below, including the links i used to acquire the information and programs. I also emailed Matthew direct to see if he could help me out. I would be open to any suggestions you might have. I just want to get this phone operational again so I can sell it. Anybody want a pretty brick? I'm hopeful because I saw in many threads where Matthew encouraged fellow brick owners that they are good if they see the screen... it's just a matter of getting the correct ROM loaded.

    Any help would be appreciated!!

    Here is what I did:

    I went to Palm's site and downloaded the 1.13 Offical Firmware ( I ran the installation application. I accepted the EULA and left it at the *Connect and hotsync* dialog/prompt. It created a \Program Files\PalmOne\Treo 650 Update folder.

    I copied this entire directory to C:\CNG-ROM and added the T3.class file used for creating the [this is standard operating procedure for creating a custom rom]. I ran java T3 from C:\CNG-ROM and my file was created.

    (note: I had to update my classpath by adding the semicolin to the end)

    now I've got the file.

    installed .NET runtilme files
    installed bootload drivers
    ran ROMtool and got the cool Grack image on the Treo

    went to the Upload tab, selected ROM zip, hunted down the
    It checked the ROM size and reported:

    Largest ROM size: 7,136,768
    Current ROM size: 7,017,882
    Waster Space: 118,886

    Then it looked to be ready to upload... so I hit the button.

    lots of text and progress... it completed and said I was good to close the program and reboot the phone. Unfortunately it just returned to that darn multicolored screen. I tried the soft reset, the hard reset, zero reset... you name it, same result. I beginning to HATE the colors red, green and blue!!

  2. #2  
    you may be able to have someone email you the rom and use bootloader to install it,
  3. #3  
    This may sound stupid. But sometimes, when I get stuck on something, I replicate the actions I took to get there in the first place. I figure if I have nothing to lose, why not try it? So, have you tried accessing the bootloader mode again? I know it's already on the screen, but maybe something is "stuck" and by trying to access it again, it will shake it loose...figuratively speaking
  4.    #4  
    saleen-s351, I would be happy to try out an original ROM if someone had one handy. I guess the info needed would be I need the ROM for the Sprint Treo650. If it happened to land in my mailbox, I would only be using it to restore my Treo to it's original factory condition. Funny though, I called Sprint today and the CS said that since my plan had switched to the 700p moments before the meltdown, the insurance would not cover a replacement of the 650. Not surprising, but certainly disappointing.

    Christinac130, I appreciate your suggestion... doesn't sound stupid at all. In fact it gave me the idea for another bit of testing. I used the ROMtool to extract the current ROM to see if there was anything on the phone... and there was. The was the same in Size and Size on disk between what I previously uploaded and what I downloaded... but the that I downloaded was only the same for the Size on Disk, the Size was slightly different (the downloaded was 60bytes while the one I uploaded was 49bytes). I'm sure there is a valid reason for this, but that's beyond my understanding. Oh, I did try starting over many times. In fact, each time I reset the phone it does go black, the the colors come back and the sounds go Bing. I wonder if maybe there is some sort of short in my treo connector that is making the hot sync switch stay on? I have tried multiple cables, no change.

    keep 'em coming! Or maybe I could try out the Linux palm OS... how's that coming?


    email: treocentral AT guessasketch DOT com
  5. #5  
    i have a 1.13a i pulled off my phone but im not sure what i need to remove so you can use it.
    i also have one with fat32 already in it.
  6. #6  
    Have you tried e-mailing mmastrac or jamesgangut? Sometimes members put their e-mail on their TreoCentral profile page. Also, you could send one of them a PM, they might get PM notification...

    I'm sure you'll be able to recover...there have been many resurrected Treos here

    Edit: I just saw a thread from James in the Custom Rom thread so he still drops in once in awhile. Maybe you can catch him...
    Last edited by Christinac130; 02/25/2007 at 09:15 PM.
  7.    #7  
    The outlook is grim... got some PMs indicating I probably had a fried motherboard. I also tried making a ROM of the 1.08 update to see if maybe it was just a flaw in my version or process... same results. I sure would like to verify that the ROMs I'm trying are valid... or I'd like to try a proven ROM. Is there anyone out there that would be willing to upload either my 1.08 or 1.13a to verify they are valid?

    Another long shot I'm thinking of trying is removing the case and making sure the hotsync contacts are not shorting out. A while back I dropped the phone in some green salsa (my favorite salsa, so I ordered a large container). I cleaned it up real nice, and it's worked ffine since... but I'm curious if the salsa had degraded the contacts. When I went to hotsync this phone before it died, it took several tries and cleanings to get the connection to work. I even scritched (less aggressive than a scratch) to get *fresh metal* on the connectors to help improve the connection. I wonder if a little shaving of metal might be loged under the little plastic bridges that separate the contacts?

    Does the case require a T-5 or T-6 to open... or both?

  8. #8  
  9. #9  
    Good luck, Chooper!
  10.    #10  
    Thanks Christinac130. Unfortunately taking it apart was not helpful. It was fun, I always like taking things apart... especially if I can manage to get them back together again without having pieces left over. So this brings me to a new question... maybe I should start a new thread.

    It was suggested that maybe my motherboard is dead. If this is the case, can I replace it with just any old motherboard I happen to find from a dead Treo650 on ebay... or must I get a Sprint Treo650 donor? Also, is there any definitive way to tell if my problem is in fact a dead motherboard? I never was able to find anyone willing to either test my ROMs or provide me with a know to be good one.

    Thanks for all the help!
  11. #11  
    Any motherboard will work you just need to flash it with the right rom. has motherboards (Sprint). Several others have done this here. I have done it on 2 different Treos myself.
    PalmIII > PalmIIIx > PalmIIIxe > TRGPro > Handera 330 > Zire71 > Treo600 > Treo650 > Treo680 > Treo750 > Centro > TreoPro > iPhone 32GB 3GS

  12.    #12  
    ok, thanks.

    I checked the site and saw they offer the Sprint motherboard only with install service $130. I mailed them to see if they would sell just the motherboard as they do for Verizon for $50. They said no. Trying to find out why.

    So from what you said it seems like I could make my previously Sprint Treo think it's a Verizon Treo by putting the Verizon motherboard in and flashing with a Verizon ROM? Besides the insignia on the front.. is there anything else in the phone that makes it one carrier vs another?


Posting Permissions