Results 1 to 8 of 8
  1.    #1  
    Hi all, I was hoping that someone here has an older version of the verizon 650 updater. I had a v1.01 that I bought off of Ebay and went to update to v1.05. The E911 updater kept looping. Now when I turn on the phone it resets the Treo. I read somewhere in this forum that going to an older version can possibly help.

    Thanks in advance.
    Last edited by heatrodyne; 02/23/2007 at 10:19 PM.
  2.    #2  
    I would even try an older verizon updater if anyone has it. Please help I would like to get this resolved tonight.

  3. #3  
    in this thread is a link to 1.04, give it a try first, then go with the 1.05.
  4.    #4  
    Thanks Firedog but according to that site ( ) the file is no longer available. Do you still have it?
  5.    #5  
    Abe Frohman uploaded the file for me and it fixed my dead phone. He is a gentleman and a scholar. Thanks for the help Abe.
  6. #6  
    I'm having the exact same problem. Every link I've found for the 1.04 updater hasn't worked. Could someone please help me?
  7. #7  
  8. #8  
    Thanks for the File, FireDog341!
    I posted the same question in another thread.
    You even included both the Windows and the MacOS versions!

    I did a little more research and tried this method to install the files Firedog provided - A method that seems to have WORKED !!!

    I started with all my files backed up and HotSynced to be current in the Palm Desktop.
    (Clear at least 11 MB of RAM space (best to simply hard reset).)

    2. I did a hard reset on the Treo. (Hold Power Button down when re-inserting the battery until the (PALM) grey circle screen appears - then press the UP arrow button to delete all info.)

    3. HotSynced the Treo again, giving it a new Profile name (guest)

    4. Installed FileZ on the Treo (guest) so I could move files.

    5. Firedog341's sharebigfile[1].com_verizon650_1.04 file expands to show a folder for the MaC OS and another for the Windows version. Each folder contains ~34 Palm Database files but no installer "wizard" app.
    The files are also available at:
    8MB Zip file:

    6. Copied all these files to the SD card for the Treo.
    Put them in a folder so I could find them all together.

    7. Put SD Card in Treo

    8. Used FileZ to move ALL the Upgrade files to the Treo Internal RAM

    9. Made sure the Treo was plugged into power.
    Then Performed a Warm Reset (press reset button in back of Treo)

    10. Upgrade then started automatically - took about 8 minutes
    If the updater doesn't start automatically, execute the "Device Customizer" application manually.
    Use with CAUTION!

    11. Turn it on again and check the version in the Phone app > Options > Phone Info.

    12. When I checked it the software version read: 1.04-VRZ.
    Also, FileZ had been removed from memory and Treo had no Profile set for it.

    I found this method at (I'm hoping that TreoCentral is OK with the link):
    Last edited by dcloye; 03/01/2007 at 12:49 AM.

Posting Permissions