Results 1 to 4 of 4
  1.    #1  
    When I insert battery or connect charger it starts to show orange logo screen, then shows for a second blue round “Palm” logo and stops functioning at all. (screen is black, no keyboard backlght)

    When I press red power button, nothing is happening. In order to bring palm logos again I have to take out the battery and put it back again.

    If I’ll press red (power) button, put the battery and release power button exactly when “round blue palm logo” appears, I will see the “Up-delete all data” (hard reset) screen. If I’ll press up after that It will turn off immediately. Again for the restarting I have to take out the battery and put it back. (IMHO, It means keyboard is probably functioning, but I don’t know if the hard reset is actually happens.

    I’ve tried to do zero-out reset many-many times, but it’s really hard to determine if I succeed to do that, since it goes to “dead” anyways.

    I’ve tried to put it in the “bootloader” mode (the rainbow screen) but couldn’t. It won’t go to that bootloader state. And my computer doesn’t see any recognized or unrecognized USB device.

    It has some strange mode too. If I’ll press reset during the time when it shows orange logo, it will turn off the screen, but keyboard’s backlight will remain On. And It will stay like that until I’ll take out the battery.

    Again, it turns off immediately after the resetting and I’ve tried to do all kind of resets including zero-out.

    I suspect that the problem is inside the ROM (could be the former owner put wrong ROM on it) or ROM loader or similar, because it shows the logos perfectly, react to the buttons. Is there any other way except bootloader or Zero-out reset to fix it?

    Please suggest what could be wrong with this treo. Or where can I fix this in NYC area?

    Thanks very much for reading this long and sorry for my English.
    Attached Images Attached Images
  2. treoluv's Avatar
    254 Posts
    Global Posts
    259 Global Posts
    Sounds like your ROM.

    If you are using Treo 650 GSM Cingular Branded, contact me via PM, I think I can help you out.
    Treo Maniac?
  3.    #3  
    Is there any way to fix it? If it's ROM problem, then what's the way to upload new ROM without bootloader.
    If there is a way to fix it I would prefer to do it myself, without sending the phone to someone.
  4. #4  
    I have the same problem in my Treo 650, I try the hard reset and did not work, do you know how can I do the other procedure (bootloader) ?

Posting Permissions