Results 1 to 4 of 4
  1.    #1  
    Recieved a refurb 700p today from Asurion, phone booted properly when the battery was first installed. Placed it on the charger. Came back 2 hours later and hit the red power button - nothing happened. Removed battery, reinserted. Nothing happens except the red "charge" light comes on and flickers rapidly. Tried turning on the phone without the battery (just plugged in), no go.

    Tried soft reset button - nothing happens. The red light doesn't even turn on or off. Tried hard reset style - nothing happens. Phone just won't turn on.

    Asurion is sending me a new one but I'm going out of town and won't be back for a few weeks. On top of that I have to send my defective one back (which works as a phone but not anything else (cracked screen). So I will be without a phone or service for a lot longer than I want to be.

    My goal is to make this current phone at least operable until the replacement arrives...any ideas how to get this thing to turn on?
  2. #2  
    Sounds like you have a dead phone. A normal phone upon insert the battery, the LED will fliker amber once and if it's connected to a charger has a solid red and shouldnt flcker rapidly. Also a good indication would be to switch the ringer to off and see if the phone vibrates. If it doesnt then you most likely have a bad unit on it you'll just have to wait for the replacement.
  3. #3  
    have you tried using a different charger? this happened to a buddy of mine. his phone was dead for a bit until he tried a different charger. or what about swapping batteries? it could be a bad battery. just a thought.
    it's not a crack house, it's a crack home.
  4.    #4  
    Tried it on the cradle, and with the battery from my 650.

    Wierd thing. This morning I reinserted the battery and it booted up again like the first time I opened the box and tried it. 5 minutes later it wouldn't "wake up", and went back to normal flickering behavior with no response to anything.

Posting Permissions