I'm having problems w/ Amazing Pyramid II. I tried getting help from the tech support of the software company, but it's been a week and no reply so I thought someone here might have some insight.

I’ve purchased this product from treo central for my treo 650 [cingular]. It worked fine for awhile but now every so often it will go to a very light blue screen when your try to start it and stay there until the treo is reset. Once that happens the .prc file must be deleted and reinstalled to work again.

Funny thing is, if I have a clean copy on my sd card and copy that over to ram, it still does it; I must install new by hotsync or by direct download via web connection on treo.

Problem happens often and treo is stable other than that.
List of other programs;
2dial - 4cast - Appforge - Backupman - Bejeweled - Butler - Callrec - Clumps - Datebook 6 - Filez - Genius - Gomoku - Icon manager - Listpro - Mring - Nevermind - Prefdoctor - Shanghai - Sudoku (Astraware) - Splashshopper - Splash id - Takephone - Volumecare - zlmanager