Results 1 to 10 of 10
  1.    #1  
    So I seems to have strange problem.

    All the keys of my treo 650 have suddenly become unresponsive. I tried to soft and hard reset and it doesn't fix it. However weird thing is if I let allow the screen to turn off and press the red power button or green call button it turns on with the keyguard message to press the center button. But when i try to press the center button nothing happens.

    Anyone can help me here?
  2. #2  
    This is a stab in the dark and relates more to the touchscreen than the keyboard, but on the off chance that the touchscreen is "thinking" it is being touched and thus preventing the keyboard activity, I will run this up the flag pole:

    If dirt or paper or the edge of a screen protector get's stuck between the case of the Treo and the touchscreen -- the touch screen senses that it is being touched and will not react to a "new" touch and seemingly becomes unresponsive. You have to remove the problem -- for the touchscreen to become responsive again. (Remove any screen protector -- if that was it -- fine-- if not take a stiff piece of paper a slide it between the case and the screen (no more than 1/8th inch in) and go all the away around to dislodge any foriegn material.)

    I have never heard of the touchscreen issue rendering the keyboard inactive -- but it is worth a shot.

    How old is the Treo and did anything happen just before this started?

    Cheers, Perry.

    I just did a test -- a continuous screen touch does render my keyboard usless -- until the touch is removed and then 2 or 3 of the alpha characters I pressed show up. . . .
    Last edited by gtwo; 11/21/2006 at 01:42 PM.
  3. wpy
    wpy is offline
    wpy's Avatar
    22 Posts
    Exactly the same problem has happened to me.. totally unresponsive keypad on my treo650 the same thing happens to if i press the green call button. i coulnd not even do a hard reset as i the power button cannot be press when reseting. I called up palm customer support and they exchanged it as it was still under warranty... seems to be a known problem to them.

  4. badgermac's Avatar
    43 Posts
    Global Posts
    50 Global Posts
    Ironically mine did the same thing 2 days ago. Called Corp. Support (it's a BlackTie and I've dealt with them before - they're wonderful) and they're doing a replacement for me.
  5. #5  
    my wife just went through an extremely painful troubleshooting / repair procedure with her treo, and after lots of agony, she found that one of the keys on the keypad was in a stuck state. this was generating the symptoms similar to what you describe where in certain situations the keyboard seems completely unresponsive, yet certain buttons work in other situations. the problem was confused/confounded by the way the hard reset procedures seemed at times to mask the problem.

    once she got the key physically unwedged, her treo was restored to working order (with the exception of that one key still being a bit hard to press).
  6.    #6  
    Ok so I've notice this new thing. If I press the return key hard then everything works fine. But once I turn it off and on it goes back to being unresponsive unless I press the return key again.
  7. #7  
    My "P" key has always been soggy. When doing text messages it often doubles or triples. All the other keys are sharp and responsive. After having this problem of the unresponsive center button and reading the above tips I checked the "P" and guess what? Stuck down. I just cleaned it with alcohol on a Q-Tip and it it working great.

    So... do you have a stuck key that is preventing the center key from working? Maybe!

    Barry Friedman
    Raspyni Brothers
    SPRINT with a TREO 755p
  8. #8  
    Wow. I was about to send my treo into Palm because of the unresponsive keyboard. After reading david's post about the stuck key I test-pressed each key and realized teh up arrow/function key didn't depress. I wedged around it, it released and my keyboard worked again. Thanks!
  9. #9  
    I just went thru this with my 650 - touchscreen was "stuck" in the lower right corner - gumming up almost all applications.

    Went to sprint store - they told me I had to go to sprint warranty center and pay $100 to get it fixed.

    Then I checked in here, grabbed a business card and ran it around the edge of the screen. Viola - it works again.

    I have had this 650 for > 2 years and have beat the h*ll out of it and it still works. Like a timex - takes a licking and keeps on ticking.
  10. #10  
    my G button doesn't work to well.... but I pull through.

Posting Permissions