Results 1 to 3 of 3
  1.    #1  
    I finally got around to installing the newest firmware on my 650. I cannot find my reg key for TreoGuard and the geekware site has not been up for a couple weeks. I tried looking through my backup files but don't see where the reg keys might be. Am I SOL?
  2. #2  
    They're usually stored in either Saved Preferences.pdb or Unsaved Preferences.pdb, but you would probably have to copy the entire file to your 650's RAM (I mean internal memory) since the prefs are all lumped together into one database. I don't know if opening either of those files with a hex editor would let you see the individual keys/codes; maybe that would be worth a try.
    "Yeah, he can talk. It's gettin' him to shut up that's the trick!"
  3. #3  
    Filez has a built-in Hex Editor, however it won't let you modify the Preferences databases. I found a nice one that will, and it also lets you copy and paste entire records from one database to another. It is a free program called Bird, and you can find it here:

    With Bird, you have to double-tap on the screen to open databases and records. The registration codes are not stored in a readable format in the preferences file, but you can just copy the record from your old backup to your current preferences file. Using this method will allow you to restore an old registration without affecting your current programs' preferences. Bird will only modify files in RAM, so you will need to backup your current Preferences files and restore the old ones to RAM.

    The preference records are usually stored in a record labeled with the creator id of the program. If you can't figure out which one to copy, after backing up your current pref files, delete them, reset, and compare the record list before and after running your program. Now restore your old backed up preference file containing the record, duplicate the file to a new name with Bird or Filez, restore your current preference files, then copy and paste the applicable record. After testing your program to make sure it worked, delete the duplicate file to tidy up.

Posting Permissions