Results 1 to 5 of 5
  1.    #1  
    I think I may have the nastiest case of "hanging while hotsync'ing" I've seen yet on this board. I've tried everything I can think of and can't seem to get all my functionality back. Behold:

    MY SYSTEM: Treo 650, Latest Sprint ROM, PalmDesktop 4.1.4, Windows XP

    ORIGINAL PROBLEM: Hotsync was hanging during the Contacts portion.

    WHAT I TRIED: Assuming the problem was on the Treo, I tried.
    * Running DBSCan on the Treo 650, no problems found. Didn't resolve issue
    * Using FileZ, deleted ContactsDB-PAdd from Treo. Now contacts
    were blank, so desktop attempted to restore them. Hung again.
    about 1/2 the records got onto my device. Subsequent hotsyncs
    hung, no change in data.

    * Using FileZ, deleted both ContactsDB-PAdd & ContactsSIMDB-PAdd
    from Treo. Same result as just above.

    * Deleted database files from Treo, AND exported all addressed from
    Palm Desktop to an "Contacts Archive" .ABA file. Deleted, address
    files from c:\program files\palm\<username>\Address. Rebooted.
    Now Palm Desktop was blank, reimported data back into Palm
    Desktop. All data looked fine. Hotsync hung again. Same result.

    NOTE: At this point, I suspected the data was corrupt on the PC side somehow. I attempted to use Tools -> Options -> Tools -> Check and repair and corrupted records on the desktop. This hung the application. Hmmm...

    * Exported contacts from desktop again, this time as an "Address Archive". Deleted contacts again from desktop, and removed address files so Desktop was again blank. Reimported the "address archive" file. Addresses now back but with no pictures. I was now able to sync!!. This led me to believe the problem was solved. But I wanted my pics back (I'd spent hours adding like 100 pics for caller ID), so I imported the original data I exported as a "contacts archive" into another "temp user." All the pictures were present. I noticed if I cut and paste even ONE record with a picture from that other user, into my main user address book, it caused the previously working hotsync to fail. I did it 3 times... twice it would just silently remove that entry from the treo that I'd just added a picture to. Other times it errored in the hotsync log saying, "Invalid version of database, doing nothing." One time it crashed after hotsync.

    SO WHERE AM I AT?: I've got the contacts back on the phone now, but I've lost all my pictures. I have all the data stored in another "user" on my desktop with the pictures but as I stated, I can't move them between users either by copying and pasting, or exporting and reimporting as a "contacts archive"

    HELP!!! Did I somehow blow up my desktop or Treo's ability to handle pictures? was the data in the original address book so hosed that ANY record from that original set blows things up? Why can't I repair any records on the PC side without hanging Palm desktop? I've spent almost 10 hours on this!

  2.    #2  
    UPDATE: I tried manually adding a picture back to an entry (as opposed to merely importing a previous record with a pic already in it) and it worked!! So I added 2-3 more pics and sync'd again. It worked! So I added 10 pictures and sync'd... and the PROBLEM IS BACK AGAIN. It now hangs on sync at the contact portion. What the #*@*??
  3.    #3  
    Boy oh boy would I love some input from the geniuses on this board. Nothing?
  4.    #4  
    I should mention that another side effect of having to export my data as an "address archive" and re-import it is I lost all my birthdays info. I had dozens in there. Help!
  5. #5  
    Sorry nobody has answered you. I am not one of the geniuses on the board but I just had your problem and it resolved more easily than yours. I don't know why. I deleted all the contacts files (three I believe) on the PC. Then I backed up the Treo onto my SD card for safekeeping (using Backupman). Then I deleted the contacts db files (I think the two you talked about) from the Treo. Then I tried to hotsync and succeeded for the first time since the problem arose. It told me it didn't backup contacs (naturally) because of something about the data or database not being the right one--or something like that. I suppose there were no contacts to go in either direction.
    Then I restored just the contacts db files from Backupman on the SD card back to the Treo. Then I ran dbScan on Contacts and tried every variation that dbscan allows (I don't really understand dbscan so I just kept trying every combination possible on contacts and addressses). It found a couple or three files here or there in various things it was doing and I just had it delete them. DBscan warned me to be sure to reset hotsync for handheld over desktop, which I did. When I was pretty sure there was nothing more dbscan could do, I hot synced and success, I was back on track. Then I backed up to Backupman once again, so all is clean, I assume. To be safe, since then, I have done a zero out reset (which takes a helluva long time to do because about 90% of the time it doesn't work) and backed up once again from Backupman. It seems to work. I suppose my problem was the Treo databases--but maybe yours was also. Was there any step I took that differed from yours? I hope your problem is cured, at any rate, and you may decide to buy a 680 as I am going to do. I really hate these phones, but need them, so my last ditch repair effort really just comprises buying a new phone. Isn't that disgusting?

Posting Permissions