Results 1 to 5 of 5
  1.    #1  
    So about a month ago, I dropped my 650 in a parking lot. It was a pretty bad fall, and flipped a few times. I was a bit concerned when this happened, but after I picked it up everything seemed to be fine, except for some scratches on the casing (no problems with the screen).

    The phone has been fine since then, until last night.

    Last night my phone was in an endless cycle of telling me what the alt key was for (as if the alt key was being held down. Everytime I hit 'ok' or 'cancel' it would clear away and then pop back up again. No other keys on the keyboard would do anything..

    I eventually removed and replaced the battery, and the phone just vibrated endlessly, and the screen didn't even light up.

    I left the battery out for a few hours, when I replaced the battery this time the phone booted up properly, however none of the keys on the keyboard work. The exception is the 'red phone' key which brings the phone to life and the 'center' key to get rid of the 'keyboard is locked warning'

    the 'home' key, the 'green phone', any of the letters, all don't work. The only way I can actually engage the phone (phone service) is to dial a number and then tap the screen when prompted with 'do you want to turn on the phone'.

    The touch screen works, however if I somehow tap out of the 'phone application' there is no way for me to get back to it, since the 'green phone' button doesn't work.

    Also, the phone isn't hot synching now.

    Took it to the cingular store, and as expected they weren't much help.

    Am I just screwed on this one? any suggestions? If the 750p or Cingular were out, I'd just suck it up and replace it. But I'm not going to replace it with another 650, so I may just jump providers and get a 700p even though that's not my preferance.

  2. #2  
    You can get back to the phone application from the launcher, its called "Phone" on my Verizon 650.

    You should be able to turn the phone on and off with your red phone button, since you said that one is still working.

    Do you hotsync with the cable? Have you tried BlueTooth? Do you have insurance?
  3. #3  
    That sounds bad. You'll definitely have to replace the keyboard or bring it in for repair if you're under warranty. Can you go into more detail on the hotsync problem?
    In Socialist Empire, tired joke laughs at YOU!
  4.    #4  
    Well, I'm baffled even more.

    I recieved a call yesterday on the phone, and after I hung up from that call, my keyboard worked fine and you couldn't tell that anything had been wrong with the phone. (although I didn't try to hotsync)

    Considering at this point that it may actually be a software issue and not a hardware/physical issue, I decided to reset to factory default. However, the keyboard, upon reset, was again locked out with only the few keys working. An attempt at hotsyncing was again unsuccessful (description below).

    Later in the afternoon I ran my finger acrossed the keys pressing all of them, and to my surprise the keys started working again. So currently my phone is functioning, however it is just with the factory default applications and the numbers that were stored on my SIM card.

    The hotsync problem.

    I hot sync using the cable. When I connect the cable the red charging light comes on. When I press the hotsync button on the cable, it awakens the phone and goes to the 'hotsync' screen.

    'connecting with the desktop using Cradle/Cable' comes up. The first of the three icons is light however not animated. (I believe it is usally animated). After about 45 seconds the error pops up:

    "The connection between your handheld computer and the desktop could not be established. Please check your setup and try again"

    I'm not really sure what can be done about this phone, if I could get it to hotsync and figure out a definitive set of steps to reengage the keyboard I could deal with a serverely crippled treo for a few weeks, but if Cingular doesn't release the new version soon, I'm just going to jump ship.

  5. #5  
    Sounds like maybe you had a stuck key before....

Posting Permissions