Results 1 to 17 of 17
  1.    #1  
    Arrghh. I have just spent the last two weeks going over every single post on the net to complete a custom ROM so that I can use a 4GB SD Card in my Treo 650 and I'm now more confused than when I started.

    I checked out Tems Guide "rom update instructions step by step" and got stuck at step 5. There are no files in the folder?

    I then checked out Shadowmites site and absolutely every post he has ever made and my brain actually hurts.

    But I know there has to be a simpler way. There has to be someone out there that can make a program to do it all for me. I'll pay $?

    If not please, I beg you please put a simple post of exactly how to make my 4gb Card work in my Palm 650 unlocked GSM I bought in Australia.
  2. #2  
    I wish Tem would put a suggestion at the top of his Thread that suggest people read about mmstrac's RomTool.
    Don't use Tem's or Shadows, use the mmstracs RomTool.

    I will be right back with the links.
    Just call me Berd.
  3. #3

    Note that I added on 09/05/06
    a Simple Step-by-Step provided by BGH
    Last edited by berdinkerdickle; 09/10/2006 at 01:33 AM.
    Just call me Berd.
  4.    #4  
    Thanks Berd - I am currently downloading rom - excellent but am having some issues. I downloaded the zip+md5 files to desktop and tried opening the file but it says that it's corrupted? What do I do?
  5.    #5  
    I then restarted and chose directory and now it has frozen? What do I do?
  6. #6  
    I'm sorry I won't be able to stay online, and won't be able to get back on until maybe monday.

    There are actaully a few different ways to use the RomTool.

    I don't personally do it as BGH.
    or even James'

    I just download my Rom into a folder I create (the files are not even zipped) make a backup, delete fatfs, replace w/ fat32, and then just upload it again, no zipping or md5 involved.

    Read up a little more, and just do it the way that seems easier for you.

    A couple reminders:
    Make sure the hotsync connection is clean and keep it connected tight, I use a rubberband.

    And first make a Backup of your existing Rom, so if something goes wrong, you have it to uplooad again.

    If you continue to have trouble, you might post your issue in mmstacs RomTool Thread, he keeps a pretty close eye on it.

    Hope all goes well, and enjoy the rest of your weekend.
    Just call me Berd.
  7.    #7  
    Ok Berd, I have progressed these last 7 hours since last we spoke. I managed to restore original Rom and phone is now working again. But here is my issue.

    I have managed to complete the rom tool exercise several times and have deleted files so that I now only have 8.3m in memory for the rom transfer. After a soft reset once updated the 650 goes into a reset loop. I have to replace new rom with old to get out of the loop.

    Is the issue one of size now?

  8. #8  
    This link

    has complete ROMs for a GSM that you just put on your SD card, run and reset the Treo and then restore your data.

    It was simple and I was done in less than a half hour.

    Many thanks to jamesgangut
  9.    #9  
    Thanks Froggy for the link and Thanks James. I noticed however that the post was quite awahile ago for the ROMs. Are they still valid to use and can I just use the ROM Tool to transfer the palmos zip file instead of doing the sd card operation?

    The more I learn the more I realise the less I know
  10.    #10  
    Has anyone else been able to successully upload the LAP Rom If so can you advise if you had the same issues?

  11.    #11  
    Ok so here is my latest update.

    I have managed to upload the LAP rom from link above and now I have a FAT32 system working on my Treo - Yeehah - But wait there are two smallish issues to fix
    1. I can't access the programs on my new 4GB sd card and scrolling through does not work. The programs are working but I can't see them on the card. I know they are working because a link to TOM TOM works fine but the link is on the Palm not on the SD card.

    2. The treo won't turn off sometimes? This is probably a bigger problem. Any ideas Guys?

  12.    #12  
    Ok I know Im obsessed but this needs to be done.

    To date - that being three solid days now I have learn't

    I used the ROM TOOL to download my original ROM to my desktop.
    I then tried uploading an altered version (Minus the fatfs.prc and replaced with Fat32.prc only) but I ended up in a continuous reset loop. Only way out was to soft reset and hold the hotsync button which allowed me into bootloader to upload orginal ROM. (Doesn't work with original ROM though -weird huh?) Can't work out why the only file I changed was the FAT32 caused the loop.

    At your advice Froggy I have uploaded a custom LAP Stripped ROM +++Fat32+++ using the ROM Tool

    I now have Firmware 1.71, Software TREO650-1.20-LAP, Hardware A, CC-Cap ENA-ENA-001, Carrier DB:255 and am able to use my 4GB SD card (which is all I wanted really)

    And this is where my issues begin. It would appear that this stripped down version cant read the card files from the 4GB SD card as was expected. As it is a stripped down version I am guessing that it doesn't have the appropriate software to function as did my previous version.

    So my question then is this - What files do I need to restore so that my Palm can read the the card from the applications menu? Oh and I no longer have any emails? I was using the outlook conduits do I have to reinstall them and if so do I need Versmail back on for it to work?

    I dont want to restore to previous version but I would like some help getting it working the way I had it.

    If anyone could customise my original ROM to make it work with Fat32 I would really appreciate it.
  13. #13  
    Is your original Rom that you downloaded from your treo in a folder able to be accessed and viewed just like any other folder on your PC, or is it in a zip format?

    If it's zipped, You may want to put your original back on your treo and see if you can download it to your pc to a folder unzipped,
    as per my "Step-by-Step" post below.
    Last edited by berdinkerdickle; 09/12/2006 at 01:23 AM.
    Just call me Berd.
  14. #14  
    Quote Originally Posted by Perfect View Post
    Thanks Berd - I am currently downloading rom - excellent but am having some issues. I downloaded the zip+md5 files to desktop and tried opening the file but it says that it's corrupted? What do I do?
    Don't dl this way, find the option to just download as unzipped files.
    Just call me Berd.
  15. #15  
    Okay, Here's my Step-by-Step.

    First Read up on Using the RomTool. and how to get it to Communicate
    with your Treo. (Bootloader/Rainbow Screen, etc.)

    1. Start the ROM tool program and let it talk with your treo.
    2. Once that is done, Create a Folder on your PC's Desktop called "MYROM".
    3. Go to the "Download Rom" tab and where it asks "Select the format to download the phones current ROM image as:" choose "Directory"
    4. choose "Browse"
    5. Browse to the "MYROM" folder you created, and click "OK".
    6. Click "Download" it should start dowloading your ROM into your "MYROM" folder.
    7. When it is done, copy your "MYROM" folder to your "My Documents" folder, and rename: "MYROM ORIG". (this is your Backup of your unaltered ROM)
    8. Go back to your "MYROM" folder you created on your Desktop, and delete the Fatfs file.
    9. Copy the Fat32 file I've attached below, into your "MYROM" folder.
    10. Go to the "Upload Rom" tab and where it asks "ROM Source" click "Select"
    11. Choose "ROM Directory"
    12. Click "Browse" browse to your "MYROM" folder and then click "Ok"
    13. Then Click "Select"

    The RomTool should now be uploading your modified ROM.
    And you will see a progress bar. (see attached)

    When the upload is complete, that progress bar will go away, and all you will see is something similar to the "upload complete" pic I attached below.
    Even though as the "upload complete" pic I attached below shows a progress bar just short of complete, you can now close the RomTool and Soft Reset your treo.


    This is how I modify my ROM. I can add or delete things just as if I was working with any folder on my Desktop.
    Attached Images Attached Images
    Attached Files Attached Files
    Last edited by berdinkerdickle; 09/11/2006 at 01:37 PM.
    Just call me Berd.
  16.    #16  
    Ok Guys first of all I'd like to thank everyone for their help and it appears that I have finally reached a status of blissfullness.

    As stated above I completed the new rom upload and decided I wanted my original rom with the FAT32.

    The reset loop was caused by the boot.cnf file. The file needs to be edited to look for fat32.prc not fatfs.prc once the file was replaced. This apprently doesn't get automatically altered through the ROM upload using ROM Tool V1.0.0

    The other issue I had was the programs on my SD card not able to be read. I had to re-install them onto the SD Card.

    Simple -

    All is no well in the world and I now have treo650 120-Lap 4gb SD card - SMOKIN!! - What an effort

  17. #17  
    Quote Originally Posted by Perfect View Post
    The reset loop was caused by the boot.cnf file. The file needs to be edited to look for fat32.prc not fatfs.prc once the file was replaced. This apprently doesn't get automatically altered through the ROM upload using ROM Tool V1.0.0
    Can anyone else confirm this please?

    I just updated my ROM this past weekend and replaced the fatfs.prc with the fat32.prc but did not know I had to update the boot.cnf file as well.

    Anyone else who did this had to update the boot.cnf file?
    Unlocked Rogers GSM Treo 650, PalmOS V5.40017, Firmware: 01.71, Software: Treo650-1.20-ENA
    Modded and hacked! Custom ROM - removed RealPlayer, Todo, Tasks, Versamail, Tips, World Clock, Launcher. Added support for FAT32 SD cards.
    Software: PDAbs, Backup.NET, Uninstall Manager, Card Reader, FileZ, Power RUN, DateBk5, DocumentsToGo, HandZipper, Chatter, TakePhone, Technician, Voice Dial, TCPMP, SpashPhoto, Insaniquarium, Memory Master, Sol Free, Palma Sutra

Posting Permissions