Hello. I've been searching forums all night and have not seen anyone else
describe the situation I am experiencing.

A few nights ago my Treo 600 came on by itself and began running a hotsync.
And then retried. And tried a few more times. The cable was not plugged in.
I guess it was reseting itself in between sync attempts otherwise it should
have eventually came up with an unsuccesful attempt. It did this for quite a while.
I could navigate to the phone and elsewhere
but before I had time to do anything, it would try again.
Then it got to a point that I could not navigate because none of the buttons
were responding. None. not even the power button for phone service. The touch screen still works though.
It finally stopped doing the constant hotsync thing.
I did a reset several times. After rebooting it again begins a sync. I can
get to the preferences screen by removing and reinserting the memory card.

After doing a reset and cancelling the hotsync the buttons and keypad work.

Of course after doing a reset the phone is not on either. When I turn the
phone on, the buttons and keypad no longer work.
I tried a hard reset (holding down the phone button while doing a reset). The
Palm logo screen comes up and that's it. It stops at that. Do a reset, and
I'm back to where I began, keys work until phone is turned on.
I don't expect anyone to have a solution to this dilema but thought some
might find it interesting. I expect I will try a battery disconnect but since
the hard reset does not work, I don't expect it will either.