Results 1 to 5 of 5
  1.    #1  
    Hi guys, newbie here. I just got a treo 650 after selling off my ipaq 6515...i missed the battery life and ease of use. Here's the situation: I popped my sim card in, powered it on and got the "sim not allowed" message at the cingular hello screen.

    I tried searching but couldnt come up with much. is it a software issue? I tried calling cingular, but the lady said that the only thing i could do was get another sim and try it out...i got my buddies sim and that didnt work either.

    I read on another forum about it possibly being a software issue and was pointed to this forum as the best place to get help.

    any info you guys can give me would me most appreciated, thanks in advance guys!
  2. #2  
    Is that a cingular sim your putting in? If not, you need to unlock the phone.
  3.    #3  
    yeah, its a cingular sim, i have cingular service.
  4. #4  
    Try to update to latest Cingular ROM. If that doesn't work I would try to unlock the phone anyway.
  5. #5  
    its a locked phone, and you need to unlock it.

    your sim might be the older AT&T sim card (or) the Cingular treo is a AT&T unit (vice versa)

    unlock the phone from a vendor on ebay.

Posting Permissions