Results 1 to 4 of 4
  1.    #1  
    Not sure whether this is a purely touch screen problem or a TomTom problem.

    I installed TomTom Navigator 5 on my Treo 650 with relatively little trouble, and connected to a Holux GPS receiver via Bluetooth. I took my new toy out on the road to try it out, successfully navigated to a point a mile or so away from home, and had just input a second point when the Touchscreen would no longer respond. I tried removing the battery to reset, and found I couldn't click the "ok" choice on the screen explaining that system time is set automatically through the SPrint Network. Further exploration found that the screen was almost, but not quite totally insensitive. on the phonepad screen, I can touch almost anywhere, and it is read by the Palm as a 5 or an 8. When I went back into TomTom, I found that sometimes it would accept touch commands, but this isn't reliable. Everything else is totally unusable with the touch screen.

    At first I blamed the new TomTom software. After searching here, I found the most common cause of touch screen failure seems to be particles lodging between the screen and the device frame, so I got a couple of different stiff cards and tried cleaning under the edges of the frame with no results.

    Any suggestions what to do? I can't think of anything but taking it to a Sprint Store and begging for help.

    I'd originally thought this was a software problem caused by installing TomTom, but now that I've pondered the situation, I don't think TomTom had anything at all to do with it directly. But at the same time I installed TomTom, I started using a powered mount (Arkon style from that holds the Treo in place by friction fit between two posts. I'm wondering if the slight tension on the Treo body this created arched the frame in front of the touch screen enough to make it open for a particle to move in.

    Still interested in any suggestions, especially on dealing with the Sprint repair people.
    Last edited by MikeBinOK; 07/02/2006 at 09:40 PM.
  2. #2  
    Not to insult your inteligence, but did you rerun the screen calibration after resetting?

    Also, I'm assuming you installed the Tom Tom software on your card. If so, try taking the card out and seeing if it changes anything. Given some of the issues I've had with it I wouldn't let the TT software off the hook just yet.
    Funny, free ecards for weird situations. No registration required. -

    Pop culture hangman using Flickr pics - SearchVoyeurMan
  3.    #3  
    The suggestion for removing the card is a good one, but I didn't try it. However, the Treo is running again. No apparent cause, I suspect I dislodged something with frantic rubbing of cards under the frame edge. Thank goodness....Even though I was secretly welcoming the opportunity to be "forced" to buy a 700p that I don't really need!
  4. #4  
    I experienced almost exactly the same symptoms today, as I activated TT. The message was not large enough db cache. TT has worked great for a month.

    On reset, the touch screen barely worked as you described. Cleaning had no effect, but finally, after several hours I figured out how to use the 5-way to activate the screen recalc, which put all in good order. Whew!

Posting Permissions