Results 1 to 7 of 7
  1.    #1  
    Kingston SD card errors

    Back in the fall, I purchased a Kingston 1GB Sd Elite Pro card to use in my Treo 650. From the first day it worked flawlessly. I used it for storing photos I had taken with my phone, storing mp3’s to use as ringtones. I also discovered I could use it as a form of portable storage for my computers and would frequently “sneakernet” documents (via a USB SD card reader) and excel sheets I needed between my Mac G5, my Pismo laptop, my homebuilt XP, and my HP work PC. Things worked great. I followed proper procedure for ejecting the card when I was done with it, and making sure that apps that were accessing the card were shutdown before I ejected and removed the card.

    Yesterday, I could no longer access the card. I had plugged it into my Mac and was saving a file. Once it was done I ejected the card and when the icon disappeared from the desktop, I removed the card. I plugged it into my USB card reader on my home pc but for some reason the card would not mount. “Removable Disk (E)” showed up in the file manager, but when I clicked on the icon, I got a “Please insert a disk” message. Thinking that it was my PC acting flaky, which it does all too often, I removed the card. (I tried ejecting it via “Right Click -> Eject” but it was not an option. And when I tried to eject it via the “Safely remove hardware” function on the task bar, the item did not show up in the list.) Before I removed it, I noticed that the light that normally would be on and flashing was off. I removed the card from my machine, inserted it into my phone and off to work I went. (Please note: I always carried the card in my phone. And when it wasn’t in my phone, it was in a card reader in one of my machines, usually the Mac.)

    When I got to work and went to retrieve some docs from it (on an older Dell that I use occasionally), the card wouldn’t mount, just like at home. So I tried it in my HP machine. The PC attempted to auto scan it (as it normally would) but found nothing. And the same icon/”please insert a disk error” was happening. When I tried it on my Mac, the card never mounted. The lights never blinked on the SD card reader when the card was in it and when I tried another SD card in it, that card didn’t mount and the activity lights didn’t flash. I found that removing the card, then removing the reader, then plugging the reader back in and then the card, the card mounts. (I tested this spare card in all my machines as well as my work machines and I found that the spare card mounted fine.)
    So I know that it is not the readers (both pluggable and the ones mounted as part of the PC) and I know it’s not the machines nor their USB drivers acting flaky.

    When I plug the card back into my Treo, an error box pops up that says “Handheld Error. The startup application for this card cannot be run.” I click ok and the screen goes white for a moment and then the card menu screen comes up. It is empty. But on the Info screen for the card, it says Free Space: 655.2M of 973.1M. There are no apps or files listed on the page. Under “More” is says:
    Type: Secure Digital Card
    Size: 655.2MB Free of 973.1MB

    317.8MB used
    655.2MB Free of 973.1MB
    Unknown (this is most likely the manufacturer name)
    Secure Digital Card
    Device Id: SD1GB_CB022864100707

    I think what happened is that somehow the master db table was corrupted. I noticed that the 9 pins looked dirty and there were some signs of wear. How can I go about restoring the db, at least to the point where I can pull off my data and reformat it? If the card won’t mount, I won’t be able to use traditional HD recovery tools to access the data. Any suggestions, any thoughts?
  2. #2  
    If you have backupbuddy for windows and palm, you can find the backup folder for that card in the backup folder of bbuddy. (assuming youve backed up recently as well)

    If not than Im not sure how to get the files back.
    ONE can be spelled as NEO.
    There is no spoon.
  3. #3  
    yosarian, sorry to hear this man. my Patriot 2GB SD lost my file also. it Treo / card reader wont read it. luckly I had backup at 3 weeks ago so i am okay. i am thinking I should of spend more $ and get a more stable SD. oh well.
    Visor -> Treo 300 -> Sprint Treo 700p -> Treo 800w
  4.    #4  
    As luck would have it, I stumbled on a little app called "Zero Assumption Recovery." I was able to install it on my work machine and it was able to retreive my data from my SD card! Made a back up of the card (which I burned to a CD), wiped the card on my Treo, put the files back onto it, purchased BackupBuddy (with the backup of the phone to the SD card mod) and implemented a nightly back up solution for the card. (I now create a 1gb disk image and copy the files to that, then move that img to my NAS back up drive.) I then bought a 2gb Kingston SD card, since I realized that I was running out of room.

    I have to read up and setup Backup Buddy to work with my HotSync so that I don't have to keep manually creating the disc image.
  5. #5  
    Wow....and all I do is copy the SD card to my laptop hard drive via Card Export or the Card Reader once a month. Watch out for BackUpBuddy Desktop during ROM upgrades....three times it's wiped me out.
  6. wbwjr's Avatar
    440 Posts
    Global Posts
    441 Global Posts
    Is there a chance you have a fake SD card? If you bought it off of Ebay, the chances are pretty good. It happened to me with a SanDisk Ultra II 2 GB. SanDisk was very helpful in assisting me with identifying the one I had as a fake. I would think it would list Kingston as the manufacturer if the card is genuine. If it is a fake that could be your problem. I hope you can recover your stuff.
  7. #7  
    I bought my 2GB SD card from kingston directly and mine also shows "UNKOWN". I guess kingston was just too lazy to enter thier name.

Posting Permissions