Results 1 to 4 of 4
  1.    #1  
    So I really like the On Demand software that came with my Sprint 700p. It's only version 1.1 (they're currently on 3.0 Pocket Express). It's worked fine since I got it. I'm annoyed it didn't come on the CD.

    Actually it hasn't worked fine, the Sports module reset the Palm every-time I hit it. I don't care about Sports so it wasn't a big deal.

    But now the Weather module is also resetting, it's probably my favorite! I've tried reinstalling from my backup folder but it doesn't help. The other modules seem to be fine. I'v tried deleting the one that seems to be the prefs for it (On Demand- Weather Info Cac.pdb) but no change. The web button at the bottom of OD is also resetting but it's possible it's always done that.

    I think this Palm "Special Edition" has a few more free modules than the current Handmark version of PE so I don't want to upgrade. I like it and it came with the Treo and I really don't want to cough up $70 a year since I shouldn't have to since they gave me this one.

    Poor planning on my part to assume the parts not in ROM would be on the CD.
    Did it come on anyone's CD?
    Is there a place where I can reload this from?

    Any thoughts,
    Last edited by garylapointe; 06/21/2006 at 02:08 AM.
  2. #2  

    Use a tool such as dBasecachetool to see how much cache you have. I would do the following:

    1. Perform a soft reset of your phone and then power on the phone and allow network connectivity as usual.

    2. Run dBasecachetool to see how much free cache you have.

    3. Run OnDemand and allow to update all your settings but DO NOT activate a module such as sports or wearther.

    4. Exit out and recheck dBasecachetool and note how much free cache you have. I was impressed at the decriment. I went from total heap size of 18874096 with 17400000 free and largest chunk of 13350233 to total heap size 18874096 with 87K free and largest chunk of 35K!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    In other words the OnDemand applicatiion is using up so much of the dBasecache that there is none left for other things to run. This is particularly true if you have a lot of applications that have background functions such as timers and e-mail programs that check in the background. Other system utility applications also operate in the background such as Volumecare that must be available to the phone application and of course Butler and Profilecare.

    When you attempt to run one of the modules in On Demand, it tries to dump the cache, but instead resets the system. This problem is particularly evident the more applications you have that run in the background. It also is very evident after running a backup program such as RescoBackup, BackupMan or BackupBuddy. They use huge amounts of cache. Perhaps the only one that does not is NVBackup. After running a backup program try to start up Blazer or OnDemand and watch what happens. It is an almost certain reset! I do not think you will see any improvement in OnDemand unless you have something that unloads the cache for you such as unCache or offLoad BUT they interfere with the usefulness of other applications such as Volumecare and Butler.

    I hope that this has helped you. I had the same problem with OnDemand and basically stopped using it because of this. To me, the interface is not worth the drain of cache and loss of other applications that I depend on. I always ask myself why I got a Treo, for sports scores or for the improvement of my business (health care)? How you answer determines your route. Sadly the dBcache is limited in this phone and many of the applications that we know and love are still not able to offload from THIS phone in particular, similar to the cache in the TX.


  3.    #3  
    So the solution is to just not use it

    I take the same goes with the newer versions of Handmark Epress (we have 1.1 they're on 3.0)?

  4.    #4  
    Mine works now!

    There's an update that it'll ask you about the next time you sync.
    It did the update and I see mine went from version 1.1.1501 to 1.1.1521.

    The sports module never worked on mine and weather stopped a few days ago and the maps stopped working today when I tried (just before the update). When I say "not working" I mean it reset my machine!

    See this thread for more info


Posting Permissions