Results 1 to 3 of 3
  1.    #1  
    I just bought a SanDisk Ultra II 512 MB memory card (one that folds back to fit into a USB slot). When I put it in my new Treo 700P it asks me if I want to reformat the memory, then it tells me "handheld cannot recognize this card"

    I called SanDisk and they had me reformat the card on my PC using FAT instead of FAT32. Card worked fine in my PC and also in my printer that has an expansion card slot, so it seems to be a problem specific to the Treo.

    Anyone out there know how to fix this?
  2. ERicJ's Avatar
    758 Posts
    Global Posts
    779 Global Posts
    Similar experience tonight, my previously working (650 and 700p) PNY 2GB SD card has suddenly stopped working.

    Or more accurately I should say my Treo700p has stopped recognizing any SD Cards. I tried a 32MB HP card and a 128MB Simpletech card and each one results in the "Unrecognized Card: The handheld cannot recognize this card." error.

    I tried reformatting the 2GB in my PC as both FAT and FAT32. Neither one enabled the card to be recognized in the 700p.

    CardInfo says the name is "*SD02G" (where * is a hollow-box character). Attempting to format from CardInfo yields: "! Format Failed".

    I tried a safe-mode reset (5-way up + reset button) and it still errors out on all three cards.

    I successfully reformatted the 2GB in my Treo650. The 650 and the PC recognize it but the 700p gives the same error.

    Only a Hard Reset enabled the 700p to recognize the card again....

  3. #3  

    Please merge these two related topics!



Posting Permissions